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What is Smart Pix Manager?
 
Smart Pix Manager is a leading solution for the management and viewing of a wide variety of formats including all common
images, multimedia (such as AVI, MPEG, MP3), Office formats (such as Word and Excel), text and web pages.
 
Smart Pix builds a media library of your multimedia collection and allows you to rapidly search and categorize files through
the use of keywords and descriptions.  Smart Pix offers the fastest keyword assignment tools with automatic functions for
generating keywords from folder names, MP3 text fields, etc.
 
Smart Pix offers advanced file security including media library encryption, password protection and even the ability to browse
files in encrypted zips. 
 
Media Libraries can be shared across a network and support for off-line browsing is included (e.g. prompting you to input the
correct CD/DVD).
 
An extensive list of other functionality is available including file management, image editing and conversion, camera
acquisition and Slideshow CD/DVD, Web Page and Thumbnail sheet creation.
 
 
Smart Pix Manager Feature Summary:
 

 Supports all common image formats, such as JPEG, GIF, Animated GIF and BMP, Raw Camera Images (Canon,
Nikon, Olympus, Pentax, etc.), Video files, such as AVI and MPEG, Sound files, such as MP3 and WAV, as well as
Office formats, Adobe Acrobat, text and HTML files

 

 Creates and maintains a media library of your files and allows you to assign and remove multiple keywords against
each file

 

 Supports AND/OR searching for files of specified keywords
 

 Allows you to add a text description and custom fields to your files, these descriptions and fields can be searched
 

 Advanced thumbnail display, printing and exporting functionality, including the ability to create thumbnail sheets and
text file description lists

 

 Web Page Creation Wizard allows you to rapidly create web sites with image indexes allowing you to browse your
images with a web browser or publish them to the Internet 

 

 Simple to use, including batch functionality for input of files and keyword assignment and removal.   If your image
collection is already sorted into folders you can add initial keywords to all your files in minutes

 

 Optional password restricted access (Media Library is encrypted!) 
 

 Optional storage of image files with false extensions (such as .SPM) to make them invisible to other users/programs
 

 Optional storage of files within the media library for high security
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 Allows you to scan and remove duplicate files from your collection
 

 Also supports standard browsing of files on your computer system
 

 Zip Support: Browse files within Zips (including encrypted ones) as if they are normal folders
 

 Viewing and editing of MP3 and WMA tags (such as Artist, song title, musical genre etc), auto insertion of MP3 and
WMA tags as keywords and batch MP3 and WMA renaming

 

 Watch Folder function automatically displays files when saved to a specified folder by another application, such as a
newsgroup downloader

 

 Slideshow feature allows you to display files in standard or random order (optionally with background music and
transition effects)

 

 Multishow feature simultaneously displays multiple images in a slideshow
 

 Creation of auto-playing Slideshow CD and DVD disks, with full support for background music and 160 transition
effects (no software needs to be installed to view)

 

 Various file display modes, including Thumbnails, Icons and Full File Details, with full support for grouping and sorting
of files

 

 Image manipulation functions including rotate, flip, resize, crop and various filters and effects.  You can even add
shadows, borders and photo frames to your images.

 

 Supports acquisition of images from USB and Twain-compliant scanners and digital cameras
 

 Files can be launched into new windows, and new windows toggled through with a single key
 

 Files can be added to Favorites for later viewing or saving as a file collection
 

 Printing of images at photo sizes (4x6", 5x7", etc), thumbnail size or posters (up to 20 x 20 pages)
 

 Can archive images directly to CD or DVD and still browse them when the CD is not inserted
 

 Support for editing of animated GIF's, Multi-Page TIFF's and AVI frame display and video capture
 

 Display of embedded (EXIF) information within images from digital cameras
 
 Advanced image editing functionality including support for "Red Eye" removal and Lossless JPEG rotation and cropping
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 Forwarding of files via E-mail with auto-convert and resize options for faster sending
 

 You can add a rating to your files and filter or sort files to see only the best (or worst) files
 

 All standard file and folder management functionality and image conversion features, including batch renaming and
batch image conversion

 
 

 
Also:

• Ten Minute Tutorial
• Testing Smart Pix Manager Functionality
• Ordering Information
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Ten Minute Tutorial
 
Smart Pix offers such a breadth of functionality that it can be quite daunting at first glance.  The key to understanding Smart
Pix is grasping how its media library works.
 

Lesson 1: The Smart Pix Media Library
 
Smart Pix uses a media library to store information about the files on your computer.  The media library contains a list of the
folders where you have files (you tell Smart Pix which folders to use), these are called your Source Folders.  
 
E.g. it might look like this
 
C:\My Pictures\Porsche
C:\My Pictures\Porsche\Racing
C:\My Pictures\Ferrari
C:\My Pictures\Mercedes
 
 
When you give Smart Pix a new Source Folder, it will look at the folder and create a list of all the files it contains, e.g.
 
C:\My Pictures\Porsche
Boxster.jpg
pawshpic.gif
Fast_Porsche.jpg
911.png
 
C:\My Pictures\Porsche\Racing
racingpic.jpg
winning.gif
overtake.gif
 
C:\My Pictures\Ferrari
Red GTO.gif
 
etc.
 
 
So Smart Pix now has a list of files on your computer (all the files in the folders that you told Smart Pix were Source Folders).
 Note that Smart Pix isn't actually storing the files, it is just storing information on where the files are on your hard drive.
 
Now all of this would be pointless were it not for Keywords.  Keywords are words or phrases you use to describe your file.
 Each file can have as many keywords as you like.  For example for an image of a red Porsche 911, you might assign the
keywords; 'Red', 'Porsche', 'German', Being Raced'.
 
So our media library might now look something like this (in actuality the media library isn't stored like this, as it uses
relational tables to make it more efficient, but this is the easiest way to conceptualize it):
 
C:\My Pictures\Porsche\
 

Boxster.jpg
German
Porsche
Red
Boxster
US Release

 
pawshpic.gif

German
Porsche
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959
Red light racing
silver

 
Fast_Porsche.jpg

German
Porsche
200 mph +
959
Rally release

 
etc..
 
 
These keywords can be searched upon once you have assigned them to your files.  For example, to locate all your images of
German racing cars, or all supermodels wearing bikini, or for whatever your image collection may be.
 
Assigning keywords need not be a chore either.  If you already have your images organized into folders then Smart Pix lets
you assign default keywords for each of your source folders, for example the folder, C:\My Pictures\Porsche, might have the
default keywords: German and Porsche.  Then whenever files from that folder are added to your media library, these keywords
will be assigned to them. 
 
There are also options to automatically generate keywords from folder or filename, and image and sound fields.
 
To add keywords for a file, you will need to display the keyword selector using View > Tool Windows > Keywords (or View >
Keyword Selector if you are using the Simplified Interface Option).
 
 
So the key to the media library is:
 

1. Telling Smart Pix where your files are, i.e. nominating the folders on your computer with images as your Source
Folders

2. When you do this Smart Pix will create a list of all the files in your Source Folders
3. Adding keywords to your files

 
If you are still having trouble getting your head around it, a good analogy is a school pupil list.  The headmaster (= you)
gives her assistant a list of all the classrooms (= Source Folder list).  The assistant (=Smart Pix) goes to each classroom and
makes a list of all the students in the class (= list of multimedia files).  For each student you add a list of the subjects they
take (= keywords).  This is all punched into a computer so now the headmaster can see at a glance all students who take
'French, English AND Latin', or 'Physics OR Chemistry', etc.
 
 
You can see and add to your list Source Folders list by selecting Library > Add new source folder Wizard..
 
 

 
All the files in these folders can be viewed in Media Library mode.  In media library mode you are offered a three methods of
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viewing your media library files:
 

• Show all media library files:  All the files in your media library are listed
• Search for files within Library:  Allows you to search for files of desired keywords or descriptions
• Show files without Keywords:  This option displays all media library files for which you have not yet assigned

keywords
 
 
 
What about Folders and Favorites modes?

• Folders mode is not a media library mode, it doesn't care about what is in your media library it just allows you to
browse folders (like Windows Explorer) and see all the files in them.

 

 
 

• Favorites mode stores a list of all the files you have marked as 'Favorites'.  In other words, if you are in any mode and
see a picture you want to come back to, you can just click 'Add to Favorites', then if you go to Favorites mode, you
will see the files you have added.

 

 
 
 

Lesson 2: File Descriptions and Find
 
When you first click on a file and select File > File Info you will see a blank description box.  This can be used for creating an
in-depth description for particular files.  These descriptions can be viewed at any time by selecting a file and hovering the
mouse over the file name area in the status bar.  You can also locate words within these descriptions by selecting Search in 
Media Library modes.
 
 

Lesson 3: Updating your Media Library
 
So, you've gone onto the 'net and downloaded 100 Pamela Anderson pics!  Or you have deleted some old files to regain some
disk space and didn't use Smart Pix!  Oh no!  Now, Smart Pix tells you it can't locate xyz.jpg and you can't access your new
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pictures.  What to do?  EASY, select Library > Current Library > Update Media Library.  Smart Pix will scan your Source
Folders, adding new files and removing those that no longer exist.
 
 

Lesson 4: Keyword Groups
 
Once you have mastered Smart Pix and have 10,000 of your favorite car pictures listed, each with 10 or so keywords, you
might find that your keyword list is too long and finding the one you desire too hard.  For this Smart Pix has optional Keyword
Groups.  Keyword Groups allow you to hide all keywords under convenient headings so you only need to display the items
you are looking for.
 
 

Lesson 5:  File Security
 
Naturally you may want to limit access to your files to other users.  For this, Smart Pix offers password protection, which
limits access to your media library to those people who know your password.  
 
However this won't stop someone from browsing to your image folder and viewing the pictures with another application, so
there are two image security options.

1. False extensions:  Windows uses the extensions (that is the letters that follow the final dot in a filename, e.g. '.jpg' in
'myimage.jpg') to determine what kind of file it is.  Smart Pix allows you to change the extension from an image
extension to something innocuous.  In this way if someone finds the files, they will not appear to be image files and
clicking on them will not display the image.  This offers a minimal level of security, which is enough to hide images
from less advanced users.

2. Encrypted Media Library storage:  For top security files should be stored within the Smart Pix media library.  The
media library is encrypted so your files can only be viewed within Smart Pix.  Smart Pix will allows you to view and
manipulate the files just as quickly and easily as if they were still in their folders.  Combined with password access
this offers the highest level of file security!

 
 
The easiest way to get underway with Smart Pix is to work through the items on the Getting Started dialog, just click Help >
Getting Started.
 
Also:

• What is Smart Pix Manager?
• Smart Pix Manager Features
• Testing Smart Pix Manager Functionality
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Testing Smart Pix Manager Functionality
 
Getting Started
 

If you click on Help > Getting Started you will be presented with a dialog which guides you through the process of getting
your Smart Pix software up and running.

 
 
Using as a simple multimedia browser
 

1.  Select 'Folders' tab
2.  Choose a folder
3.  Select a file
4.  Zoom, perform slide shows, etc. as below
 
View the Folders mode section for more detail

 
 
To utilize the powerful cataloguing and search features of Smart Pix Manager
 

Cataloguing functionality
 

1.  Select 'Library > Add Files to Library Wizard' from the menu
2.  Select a folder where you have a multimedia files
3.  Select the returned folder(s) and click 'Default Keywords' to some new keywords that files from this folder have in

common.  Click OK.
4.  Add some more Folders
5.  Close the Options dialog, select the 'Media Library' tab to the left of the image window.
6.  From the drop down list at the top select 'Show All Media Library Files'
7.  Display the Keyword selector using View > Tool Windows > Keywords (or View > Keywords Selector if you are

using the simplified interface)
8.  Go through your files adding new keywords specific to particular files (multiple assignment is OK, too).
 
View the Keywords section for more detail

 
 

Searching functionality
 

1.  From the Drop down list select 'Search for files in the Library'
2.  From the next option select:

• All files in media library: The complete list of files in your media library is displayed
• Files with ANY selected keywords: Searches for files that have at least one of the keywords you

specify
• Files with ALL selected keywords: Searches for files that have all of the keywords you specify
• Search text fields or content of files: Searches for files containing the text that you specify (e.g.

within the file content or descriptions)
• Files without keywords assigned: Displays all files which you have not yet given keywords

3.  Highlight the keywords that you want to search on.
4.  Click search
5.  A list of "hits" will appear based on your search.
 
View the Media Library mode section for more detail

 
 

Viewing functionality
• You can zoom in on an image by pressing the Equals key, or if it is smaller that the viewing window you can stretch

it to full window size by pressing Ctrl+Equals
• You can zoom out of an image by pressing the Minus key or you can shrink it to the windows size by pressing
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Ctrl+Minus
• If the image size is larger than the window you can scroll the image by clicking and dragging it
• You can open files in a new file window by pressing 'Ctrl+N'
• You can view full-screen by pressing 'Space'.
• You can play the files in sequence by pressing 'Alt+S' or View > Slideshow (delay between flip can be

increased/decreased with the Comma and Period keys).
• You can rotate, resize or crop an image by selecting the relevant option under the Image menu

See the File Viewing section for more detail
 
 
 
Also:

• What is Smart Pix Manager?
• Ten Minute Tutorial
• Smart Pix Manager Features

Page 11



Overview
 
Smart Pix Manager offers three methods to access the files on your computer:
 

Media Library mode
 
Display all files listed in your media library and allows you to perform searches to locate a particular selection
 

Folders mode
 
Viewing files directly on your hard drive, CD, DVD's etc.
 

Favorites mode
 
While browsing through your files in any of the other modes you may want to mark a file so you can come back
to it later.  In Favorites mode you can view the files you have marked as a Favorite

 
 
You change the mode by selecting the relevant tab to the left of the image window.
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Media Library Mode
 
Media Library mode is for browsing the files that you have added to your media library.
 

 
 
At the top is a drop down box which allows you to specify how to view your media library files.  You can specify the following
search modes

• All files in media library: The complete list of files in your media library is displayed
• Files with ANY selected keywords: Searches for files that have at least one of the keywords you specify
• Files with ALL selected keywords: Searches for files that have all of the keywords you specify
• Search text fields or content of files: Searches for files containing the text that you specify (e.g. within the file

content or descriptions)
• Files without keywords assigned: Displays all files which you have not yet given keywords

 
 
To perform a keyword search of your files:
 

1.  Select one of the two keyword search methods from the top drop-down box:
• "Files with ANY selected keywords" if you want to view files that have any of the keywords (Boolean OR).
• "Files with ALL selected keywords" if you want to only retrieve files that have all the keywords (Boolean AND)

 
2.  Select all the keywords that you want the returned files to contain
 

For example, if you have a media library of car images, where each image has a keyword for its type, color and country
of manufacture.  If you have selected Red and Porsche and click on 'Match all selected' above it will return only red
Porsches, if you choose 'Match any selected it will retrieve all images of cars which are red or are Porsches, e.g. red
Hondas, red Lotuses, green Porsches and blue Porsches.
 
If you want to exclude certain keywords you also depress the 'Not' button and choose the keywords to block.

 
3.  Hit 'Search' to perform your query.
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To perform a text search of your files:
 

1.  Select from the top drop-down box, "Search text fields or content of files"
 
2.  Select the field that you wish to search (usually this will be the Description or the File content)
 
3.  Enter the text you are searching for
• Match Case?

By default the case of the search text is ignored, i.e. 'New Zealand' is considered a match for 'new zealand'.   If you
prefer you can force it only return hits with the same case as your search text by checking this option.

 
4.  Hit 'Search' to perform your query.

 
 
Filtering your Media Library
 

You can also hide particular files in your media library by using the filtering function, which allows you to specify certain
parameters that each file must match to be displayed, e.g. take before a certain date, or with a certain rating.
 
To filter your media library click the "Filter" button at the bottom of the search box of the media library tab.
 
Note: The Filter button is not displayed if you are using the Simplified Interface.
 
You can filter on the following files:
• File Date: Filtering files by the date they were created (e.g. to view photos of a particular year)
• Viewed Date : Show only the files you have not viewed in a long time
• File Size : Hide files that are particularly large or small
• Rating: Hide files that you have given a poor ranking using the Ratings toolbar
• Library Storage Method: Filter by the method that files are listed in the media library
• File Extension: Display only a particular file type

To remove filtering from your media library click the "Clear Filter" button
 
 
 
You can add and remove keywords from your files, edit descriptions as well as perform normal viewing functions and file
management tasks.  All panels support multiple selection.
 
 
Also:

• Overview of Modes
• Folders mode
• Favorites mode
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Folders Mode
 
Folders mode enables you to browse the files on your computer, network, CDs, DVDs, etc.
 

 
 
Click on any folder to view its contents.
 
You can also display files in all sub-folders of the current folder by right-clicking it and selecting "Show Sub-Folders"
 
 
Folders Toolbar
 

Beneath the Drive Selection box is a panel for extra functions:
• Back/Forward:  Navigate through previously visited folders
• New Folder:  Create a folder beneath the selected folder
• Favorite Folders:  Allows you to add or go to an item in your Favorite Folders list
• Add Folder to Library:  Adds the current folder and its files to your media library

 
You can add and remove keywords from your files, edit descriptions as well as perform normal viewing functions and file
management tasks.  All panels support multiple selection.  Folder functions are available by selecting a folder and clicking on
it with the right mouse button.
 
Note: Smart Pix will automatically update the media library listing if you perform any actions (such as move or delete).  Files
listed in your media library will have the letters "Lib" at the end of their description in the status bar.
 
 
Also:

• Overview
• Media Library Files mode
• Favorites mode
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Favorites Mode
 
Favorites Mode is for viewing files that you have tagged during this Smart Pix Manager session or from a Favorite collection
that you have loaded.
 

 
 
The Favorites tab contains the following items:
 
FAVORITES LIST:

 
This displays the current Favorites list, if you have not loaded a Favorites List then it shows <default> meaning that it only
contains files that you have added in this Smart Pix Manager session.  If you click on the down arrow on the right a list of
all your recent Favorites lists will be displayed, you can load a Favorites list by selecting it.
 
Click the Save button for a list of Favorites List file functions:
• Save Favorites List

This will save the current Favorites List to disk, if it is the <default> file you will be prompted for a file name.  Using
'Save File' is usually unnecessary, as Smart Pix Manager will prompt you to save the current Favorites List when
closing (Note: you are not prompted to save the <default> file)

 
• Save Favorites List As..

This allows you to save the current Favorites List with a new name; i.e. you might want to save a collection of favorite
pictures for showing to a friend later.

 
• New Favorites List

Creates an empty Favorites List
 

• Open Favorites List
Allows you to browse for a Favorites List to open

 
• Merge Favorites List with

Adds the contents of another Favorites List to the current one
 

• Delete Current Favorites List
This will delete the current Favorites List (not the files) from your hard disk.

 
 
FAVORITES LIST
 

This is the list of all the Favorites:
- that you have tagged in this session if it is the <default> file 
- that are stored in the loaded Favorites List

 
 
FAVORITES FUNCTIONS
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• Up/Down Buttons

The Up and Down buttons allow you to sort your slideshow into a preferred order.  Select the file whose position you
want to change and then use the buttons to move it to its new location. NOTE: For most tasks it is quicker to reorder
your files by dragging and dropping them
 

• Remove
Removes the current file from the Favorites List.  It does NOT delete the original file or listing in the media library.

 
• Update

Checks your Favorites List for links to files that no longer exist.
 

• Clear All
This clears all files from the list.  It does NOT delete the original files, nor the listings your media library.
 

You can add and remove keywords from your files, edit descriptions as well as perform normal viewing functions and file
management tasks.  All panels support multiple selection.
 
Note: Smart Pix will automatically update the media library listing if you perform any actions (such as move or delete).  Files
listed in your media library will have the letters "Lib" at the end of their description in the status bar.
 
 
Also:

• Overview
• Media Library Files mode
• Folders mode
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Menu
 
File Menu (functions for selected files)
 
File Information Displays information on the selected file and allows you to view and edit the description for the file 

    

New Create a new image file, text file, folder or Favorites list

Save Saves changes to the current file

Save as... Saves changes to the current file with a new filename

    

Add to Favorites Adds the selected file(s) to the current Favorites list

Library Storage Method Modify the way the selected file(s) is listed in the media library

   

Rename Rename the selected file(s)

Move File Move the selected file(s) to a different folder

Copy File Copy the selected file(s) to a different folder

Delete Remove the selected file(s) from your computer

Archive to CD Move/copy the file(s) to CD or DVD

E-mail File Forwards the selected files via e-mail

Print Print the current file(s) 

   

Watch Folder Monitors a specified folder and displays any files that are added

   

Exit Closes Smart Pix Manager
 
 
 
Media Library Menu (functions for current media library)
 
Media Library Info Settings and statistical information for the current media library

   

New Media Library Create a new media library

Open Media Library Open an existing media library

Reopen Provides a list of recently used Folders to open

Import and Export..  

     Import... Import media library entries from a text file

     Export... Export media library entries to a text file

     Back Up Exports your media library to a back up file

   

Add Files to Library
Wizard

Displays a wizard to assist you in adding files to your media library

   

Edit Keywords Edit the keywords of the current media library

Settings and Source
Folders

Displays your media library settings and current list of File Source Folders

Update Media Library Checks your source folders for new or deleted files

Check for Duplicate Files Scan files listed in your media library and advise of any that are identical

   

Manage Media Libraries Move, copy or delete media libraries
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Edit Menu (functions for manipulating the displayed file)

 
Undo Changes Undoes the last performed action

   

Cut Cut the image selection/selected text to the clipboard

Copy Copy the image/image selection/video frame/selected text to the clipboard

Paste Paste image to selection/Paste text to current position

Paste as New Image Paste an image from the clipboard as a new image

   

Rotate and Flip Image Perform a custom rotation or flip the image horizontally or vertically

Resize Image Resizes the image to new dimensions

Crop Image Remove everything outside of the selection rectangle from the image

Remove Red Eye Reduces the "Red Eye" effect caused during flash photography

Other Editing  

     Image Attributes View and change the attributes of the file, such as its size and color depth

     Add Frame, Border or
Shadow

Choose from a selection of frames, borders and shadows to add to the current image

     Insert Text into Image Add a block of text to the current image which will be displayed when anybody views it

     Merge Image Merge the contents of the image with another one

     Automatically Rotate
Images

Rotate misaligned images based on digital camera orientation fields

     Edit GIF
Transparency Color

Set the transparent color of a GIF image

Colors and Effects  

     Auto Color Enhance Maximizes the contrast of the image

     Adjust Colors Perform custom color adjustments

     Image Effects Perform custom image effects

     Sharpen Image Makes a blurred image appear more sharp

     Grey Scale Removes all color from the image

     Negative Creates a negative of the image

Edit Animated GIF... Edit the frames of an animated GIF

Edit TIFF Pages... Edit the pages of a multi-page TIFF

   

Cursor Action Specify what function the cursor has

   

Open in Editor Opens the selected file(s) in its editing application

   

Batch Conversion Automatically convert and edit the current selection of images

 
 
 
View Menu
 
File Display Specify how the files should be displayed

File Sorting Specify the sorting of the displayed files

File Type Filter Limit display of files to a specified type, such as images or videos
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Find File Locate a file within the current folder or its sub-folders (Folders mode only)

   

Open in New Window Launches the file in a new file window

Display Full-Screen Displays the file using the full-screen

   

Slideshow Display the files in an automated sequence

Multishow Display multiple images in an automated sequence

   

Zoom Increase or decrease the image or video size

Shrink to Window Reduce images/videos to fit in the available window (toggle)

   

Toolbars Choose which toolbars are displayed

Tool Windows Choose which Tool Windows are displayed
 
 

 
Tools Menu (Settings and functions related to Files and Thumbnails)
 
Print/Export File Lists Print or save text information on files in the current mode

Print/Export Thumb
Sheets

Print or save thumbnail sheets for files in the current mode

Web Page Creation
Wizard

Displays the HTML creation wizard so that you can create HTML indexes of files in the current
mode

Create Slideshow
CD/DVD

Create a auto-playing slideshow disk using the current image and/or video selection

   

Acquire from
Camera/Scanner

Retrieved images and videos from a connected scanner or digital camera

   

Supported Formats Specify which formats to display and support

Options Set program options

 
 
 
Window Menu (for manipulation of the program windows)

 
Show all Other Windows Arranges the layout of all other windows and displays them all on the screen at once

Add all to Favorites Add the filename of each open file to the current Favorites list

Close all Other Windows Close all windows except the main one
 
 
 
Help Menu (program help and registration information)
 
Contents Show Help contents

Keyboard Shortcuts Information on the keys you can use for quicker usage

   

Xequte Web Site Opens your web browser at www.xequte.com

Register Online Opens your web browser the Xequte online store

   

Troubleshooting FAQ Provides answers to Frequently Asked Questions
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Xequte Support Site Opens your web browser at www.xequte.com/support

Contact Support Send a message to the Xequte Support Team

   

Tip of the Day Displays a random Tip of the Day

Getting Started Display the getting started dialog

Registration Info Information on registering Smart Pix Manager

About.. Information about Smart Pix Manager
 
 
 
Also:

• Toolbars
• Keyboard Shortcuts
• Mouse Shortcuts
• Status Bar
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Toolbars
 
Smart Pix Manager provides a variety of toolbars, which may be displayed depending on the current file type or mode.  You
can toggle the display of toolbars by selecting View > Toolbars..
 
Note:  If you are using the "Simplified Interface" option then some toolbars will be hidden.
 
Main Toolbar:

 

 First File:  Move to the first file in the file grid
 

 Previous File:  Move to the previous file in the file grid
 

 Next File:  Move to the next file in the file grid
 

 Last File:  Move to the last file in the file grid
 

 Next Page:  Move to the next page (when viewing a Multi-page TIFF)
 

 Previous Page:  Move to the previous page (when viewing a Multi-page TIFF)
 

 Slideshow:  Starts or stops the slideshow (Toggle).
 

 Multishow:  Starts or stops the multishow (Toggle).
 

 Change the current method of displaying files
 

 File Types:  Choose which support file types you want to display
 

 Sorting:  Choose the order that your files are displayed
 

 Full-screen:  Shows the file in Full-screen mode (Toggle)
 

 Open in New Window:  Launches the file in a new file window
 

 Zoom in:  Enlarges the displayed image or video
 

 Zoom out: Reduces the displayed image or video
 

 File Information:  Displays information on the current file and allows you to change its keywords, description and
file attribute
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 Print:  Prints the current file
 

 Add File to Media Library:  Adds the selected file(s) to your media library
 

 Add File to Favorites:  Adds the selected file(s) to the current Favorites list
 

 Rename: Rename the selected file(s).  If you are in Folders mode and a folder is selected then it will allow you to
rename the folder.

 

 Move:  Move the selected file(s) to a new folder
 

 Copy:  Copy the selected file(s) to a new folder
 

 Delete:  Remove the selected file(s) from your computer
 

 Email Files: Forward the selected file(s) to another person via e-mail
 

 Edit Files:  Launches the file into the editor that you have specified for this file type
 
 
Ratings Toolbar:

 
The Ratings toolbar allows you to rank your files.  In Full File Details mode you can display a ratings column use View >
Select Columns > Rating.  You can sort by Ratings using View > Sorting > Sort by Rating.  You can also filter by the
Rating when in Media Library mode.

 

 Rating:  Click as many stars as required to rank the selected file(s)
 

 
File Grid Toolbar:

 
The File Grid toolbar appears beneath the file grid and allows you to manipulate the displayed files
 

 Grid Full Screen:  Displays the File Grid full screen
 

 Show Preview (Full Details mode Only):  Displays the file description below the filename
 

 Show Grouping Area (Full Details mode Only):  Shows an area where you can group files by dragging and dropping
 

 Show Column Selector (Full Details mode Only): Shows a list of all the available columns which can be added to
the display

 

 Select All:  Marks all files as selected
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Image Editing Toolbar:

 
The image editing toolbar is only available when an image file is selected
 

 Drag Image:  Allows you to scroll an image by clicking it and dragging
 

 Zoom Selection:  Allows you to zoom into an area of your image by selecting it
 

 Rectangular Selection:  Allows you to select a rectangular area of your image for editing
 

 Polygon Selection:  Allows you to select an irregular shaped area of your image for editing
 

 Elliptical Selection:  Allows you to select an elliptical area of your image for editing
 

 Select Color:  When you click on an image the area contain the same color as that you clicked will be selected
 

 Cut Image Selection:  Will cut the selected area of image and copy it to the clipboard
 

 Copy Image (Selection):  If the image is selected then the selected portion will copied to the clipboard, otherwise
the entire image will be copied to the clipboard

 

 Paste to Selection:  An image will be pasted from the clipboard and stretched to fit the area of image that you have
selected

 

 Undo Changes:  Will undo the last change to your image
 

 Redo Change:  Redoes the last action that was undone
 

 Rotate Left:  Will rotate the image 90 degrees anticlockwise
 

 Rotate Right:  Will rotate the image 90 degrees clockwise
 

 Rotate/Transform:  Rotate the image by a specific degree or flip it vertically or horizontally
 

 Crop Image to Selection:  Removes the section of image around your selection (i.e. only the image selection will
remain)

 

 Resize Image:  Specify new dimensions for the image.  The image will then be shrunk or stretched to fit your
specified dimensions
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 Remove Red Eye:  When taking photos using a flash you will often find that the eyes of your subjects appear
bright red. If you have selected an area of the image then this function will remove any "Red Eye" effect within
eyes in that selection.

 

 Color Effects:  Modify the colors of the current image
 

 Maximize Contrast:  If you have an image with poor contrast then this function will stretch the available contrast
range

 

 Acquire Images:  Retrieve images from connected scanners and cameras
 

 
 
Text Editing Toolbar:

 
The text editing toolbar is only available when a text file is selected
 

 Word Wrap:  Limits the width of the text to the size of your text window so that you can view it without scrolling
horizontally

 

 Automatic Scrolling:  This function will automatically scroll the displayed document as you read it. Use the
Comma/Period to decrease or increase the scrolling speed

 

 Cut Text:  Will cut the selected text and copy it to the clipboard
 

 Copy Text: Will copy the selected text to the clipboard
 

 Paste:  Text on the clipboard will be pasted to the current position
 

 Undo Changes:  Will undo your last change
 
Font Name:  Specifies a font for the selected text *
 
Font Size:  Specifies the size of the selected text *
 
Font Color:  Specifies the color of the selected text *
 

 Bold:  Makes the selected text Bold *
 

 Italics:  Italicizes  the selected text *
 

 Underline:  Underlines the selected text *
 

 Left Align:  Aligns the selected text to the left of the document *
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 Center Align:  Centers the selected text within the document *
 

 Right Align:  Aligns the selected text to the right of the document *
 

 Add Bullets:  Adds bullets to the selected text *
 
 
* These options are only available with rich text.  If you are editing a plain text file you will be prompted to convert the file to
rich text.
 
 

Zoom Toolbar:
 
The Zoom toolbar provides real time zooming of the displayed image or video.  You can also click the Zoom display text
area to quickly toggle between shrunk to fit and full size display

 

 Zoom: Drag the track bar to set the level of zoom for the current image or video
 
 
 

Other Toolbars:
• Multimedia Toolbar
• Slideshow Toolbar
• Toolbar in New Windows

 
 

Also:
• Menu Bar
• Keyboard Shortcuts
• Mouse Shortcuts
• Status Bar
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Keyboard Shortcuts
 
Navigation:
 
Cursor Left/Up Previous File

Cursor Right/Down Next File

PageUp/PageDown Moves to the previous/next screen of files

Home/End First/Last File

Alt+Arrow keys Scroll Image Up/Down/Left/Right

*  or  / Display a file at random

Backspace Move up to higher folder (or group if a keyword list is selected)

Ctrl + A Select all files

First letter of a
filename

Go to that file (or keyword if a keyword list is selected)

F3 Search for a file (Folders mode)

Shift+F3 Repeat the last search (Folders mode)
 
 
 
Viewing:

 
Space or F11 Toggles Full-screen view On/Off

Ctrl+Space Hide everything except the image (toggle)

Minus Key Zoom out of image or video

Ctrl+Minus Key Toggles shrink to fit

Plus or Equals Key Zoom in of image or video

Ctrl+Plus or Equals
Key

Toggles stretch to fit

Ctrl+F5 Reloads current file

Ctrl+N Opens the file in a new file window

Alt+P Play/Pause the Multimedia File

Period/Comma Keys Increase/Decrease volume

Alt+Z Perform a custom zoom
 
 
 
Slideshow:
 
Alt+S Toggle Slideshow On/Off

Alt+U Pause the Slideshow

Period/Comma Keys Increase/Decrease delay between file flip
 
 
 
File Functions:
 
Alt+Enter Display information for the current file

Delete Removes the selected file(s)

Shift+Delete Removes the selected file(s) without using the Recycle Bin

F2 Rename File/folder
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Ctrl+F/Shift+Alt+F or 
Ctrl+B/Alt+B

Add/Remove the current file(s) from Favorites

Ctrl+P Print file or thumbnails

Ctrl+T Set Date and Time of selected file

Alt+X or Alt+M Move the selected file(s) 

Shift+Alt+X or 
Shift+Alt+M

Move files to the last folder moved to

Alt+C Copy the selected file(s)

Shift+Alt+C Copy files to the last folder copied to

Ctrl+I Send the selected file(s) by E-mail

Ctrl+Alt+I
Embed the file description into the IPTC fields of the image
(JPEG only)

 
 
 
Media Library Functions:

 
Shift+K Display the Keyword Tool Window

Shift+D Display the Description Tool Window

Ctrl+K Edit Keywords

Shift+Alt+K Create new keyword

Alt+K Quickly add keywords to the current file

Ctrl+C Copy the selected keywords to the clipboard

Ctrl+V Paste a selection of keywords from the clipboard

Ctrl+D/Alt+D Insert/Remove the select file(s) into/from the media library
 
 
 
Editing Functions:
 
Ctrl+S Save changes to the current file

Ctrl+Shift+S Prompts for a filename to save the current file to

Ctrl+X Cut the image selection/selected text to the clipboard

Ctrl+Alt+X Crop the image to the current selection (i.e. remove everything outside the selection)

Ctrl+C Copy the image/image selection/video frame/selected text to the clipboard

Ctrl+V Paste image to selection/Paste text to current position

Ctrl+Z Undo the previous action

Ctrl+Y Redo the previous action

Ctrl+Alt+F Rotate or Flip Image

Ctrl+Comma Rotate Image 90 deg. CCW

Ctrl+Period Rotate Image 90 deg. CW

Ctrl+Alt+R Resize Image

Ctrl+Alt+C Crop Image

Ctrl+Alt+E Remove the red eye effect from the selection

Ctrl+Alt+B Perform a batch conversion or editing on the selected images

Ctrl+E Launch the selected file(s) in an external editor

Ctrl+B Set the selected text as Bold

Ctrl+I Italicize the selected text

Ctrl+U Underline the selected text
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Alt+Mouse
Holding down the Alt key while resizing a selection with the mouse will maintain the ratio of the
selection, e.g. create a round selection with the ellipse tool, or a square selection with the rectangular
tool

Shift+Click Holding down the Shift Key while selecting portions of the image will create multiple selection
 
 
 
Application View Settings:
 
Shift+Ctrl+M Toggles display of menu (Not available in Full Screen mode)

Shift+Ctrl+B Toggles display of status bar

Shift+Esc Reset view options to default

F12 Minimizes the application (Boss key)

F5 Update the file display (in Folders Mode)
 
 
 
Windows:
 
Ctrl+W or F6 Toggles through all open file windows.

Shift+W Switches to the main window

Shift+Ctrl+W Close all file windows (except the main one)

Ctrl+F4 Close secondary window
 
 
 
Other:

 
F1 Help (context sensitive)

Shift+Ctrl+U Remove all File Associations

Alt+F4 Exit Smart Pix Manager

Shift+T Use display as thumbnail

Shift+Ctrl+T Load custom thumbnail from file

Shift+Ctrl+D Set Media Library sharing settings
 
 
 
Also:

• Toolbars
• Menu Bar
• Mouse Shortcuts
• Status Bar
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Mouse Shortcuts
 
Mouse Drag and Drop Shortcuts:
 
Smart Pix Manager supports drag drop integration with Explorer and any other OLE compliant applications:
 
 
Dragging from Smart Pix:

• Dragging from the file box in Folders or Favorites mode will copy, move or link to a file
• Dragging from the file box in Media Library mode will copy or link to a file
• Dragging from the folder box in Folders mode will copy, move or link to a folder

 
Dragging to Smart Pix:

• Dropping a file on the file or folder box in Folders mode will copy, move or link to a file or folder
• Dropping files or folders onto the file box in Media Library mode will add them to the media library
• Dropping files onto the file box in Favorites mode will create add the files to the Favorites list
• Dropping a file on the image window, new image window or title bar will display the file

 
Dragging within Smart Pix:

• Dragging and Dropping files within the Favorites list will allow you to change their order
• Dragging and Dropping files and folders within the folder box and between the folder box and the file box will move or

copy the file or folder
• Dragging and Dropping keywords from the All Keywords box to the Keywords of Image box will add the keyword(s) to

the selected file(s)
• Dragging and Dropping keywords from the Keywords of File box to the All Keywords box will remove the keyword(s)

from the selected file(s)
• Dragging keywords from the keyword toolbar and dropping them on files, will add the keywords to the files

 
Mouse Double-click Shortcuts:

• On the image:  Hide everything bar the image
• On a filename:  Display the file in Full-screen mode
• On the Toolbar:  Hide the Toolbar
• On the Status Bar:  Hide the Status Bar
• On a folder (in Move/Copy Dialog or Quick Move): Move or copy to selected folder
• On a filename in Windows Explorer:  Will display the file in Smart Pix Manager (Note:
• Only if you have set Smart Pix Manager as the default viewer for that file type)
• On a keyword (in Search mode):  Perform Search
• On a keyword (Keyword Toolbar, Keywords of File):  Remove keyword from selected file(s)
• On a keyword (Keyword Toolbar, All Keywords):  Add keyword to selected file(s)

 
Mouse Wheel Shortcuts:
(Note: actual function depends on your Wheel Mouse setting in Options)

• During Full-Screen mode:  Browses forward/backward though files
• During a slideshow:  Increases/decreases the flip delay

 
 
Also:

• Toolbars
• Menu Bar
• Keyboard Shortcuts
• Status Bar
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Status Bar
 
The status bar has four sections:
 
1.  Zoom Options
 

The leftmost section indicates whether hte image has been shrunk for display or shown full size.  If you click on this
section you can toggle these settings or perform zoom.
 
For Text files a 'Wrap' icon will be displayed if you have word wrap enabled.
 
 

2.  Zoom Factor/Progress Display
 

The second section displays the zoom factor of the current file.
During file loading it displays a bar graph showing load progress for the current file.
While performing other functions, such as rotation, file deletion the bar graph will display their progress.
 
 

3.  File Selection Information
 

The third section displays:
• Normally:  How many files are currently selected of the total number of files available.
• In slideshow or Full-screen mode:  Which file is currently selected of the total number of files.
• When changing slideshow delay:  If you change the slideshow delay (such as with the < and > keys) it displays the

number of seconds between file flip
 
4.  File Information
 

The rightmost section displays the name of the selected file, and other details such as image dimensions, or multimedia
length.  In Folders or Favorites mode the letters "Lib" will also appear if the displayed file is also listed in the media library.
 
Hovering the mouse over the file information section will give you more information on the file

 
 
 
Also:

• Toolbars
• Menu Bar
• Keyboard Shortcuts
• Mouse Shortcuts
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 File Display Options
 
Smart Pix Manager provides the following methods of displaying your files:

• Full File Details
Multiple columns are displayed and you can sort items by clicking the column header, can group items by dragging
the column header to the grouping area and can add and remove columns

 
• Large Thumbnails *

Each file is displayed as a small image in a long scrollable strip.  You can specify the size of large thumbnails under 
options.

 
• Thumbnails

Thumbnails are displayed with their filename.  You can specify the size of the thumbnails under options.
 

• Small Thumbs *
Thumbnails are displayed at half size with their filename, file size and dimensions

 
• Filenames *

Only icons and filenames are displayed
 
 
* These options are not available if you are using the 'Simplified Interface' Option.

 
 
 
Controls:

• Toolbar: or 
• Menu: View > File Display

 
 
 
Exporting File Information
 

You can also save and print the file information and/or thumbnails.  The following options are available:
• Print file details or Save file details to a text file
• Print pages of thumbnails or save pages of thumbnails to an image file
• Create a web site (HTML pages) from your files
• Create Auto-Playing Slideshow CD/DVD Disks
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Viewing Files Overview
 
Navigation:

• Right cursor takes you to the next file in the file list box
• Left cursor takes you to the previous file in the file list box
• * or / key selects a file at random from the list box
• Home takes you to the first file in the file list box
• End takes you to the last file in the file list box
• PageUp takes you back several files 
• PageDown takes you forward several files
• You can also browse forward/backward through files using a mouse wheel in full-screen mode (you need to have

selected the setting under Options)
 
 

Full-Screen Mode
 

Press 'Space' for Full-Screen Mode or 'Ctrl+Space' to hide everything bar the image.
(There are a number of options for Full-Screen mode)

 
 

Image Zooming
 
You can zoom in and out of an image or a video using the Equals and Minus.  The current zoom factor is displayed in the
left panel of the status bar.  Zoom is generally performed in steps of 25%, however if you select View > Zoom > Custom
or click on the zoom section of the status bar then you can enter an exact zoom factor.  Note that unlike the Stretch to
fit and Shrink to fit options below, your zoom factor is only kept for the current image and will return to the default for the
next viewed image.
 
You can display a zoom toolbar by selecting View > Toolbars > Zoom
 
Controls:

- Toolbar:   / 
- Menu:  View > Zoom..
- Keyboard: Equals Key/Minus

 
 
 

Shrink to Fit
 

If the shrink option is enabled then an image or video larger than the window size will be reduced to fit in the available
window space (while maintaining the aspect ratio).
If Shrink to Fit is enabled a '-' will appear in the leftmost section of the status bar. 

 
Controls:
- Menu: View > Shrink to fit
- Keyboard: Ctrl+Minus

 
 
 
Other:

• Playing Multimedia Files
• Full Screen Mode
• Opening a file in a new file window
• Slideshow and Multishow
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• File Information
• Printing Files
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Playing Multimedia Files
 
Smart Pix Manager can play a variety of Multimedia files, please see the supported formats section to learn which formats are
supported and how to support further formats.
 
 
Multimedia Toolbar
 
When a multimedia file is loaded then the multimedia file is displayed, by default.  If you have hidden it you can re-display it
using View > Toolbars > Multimedia
 

 Rewind Multimedia File
 

 Fast Forward Multimedia File
 

 Play the Multimedia File
 

 Pause Multimedia File playback
 

 Stop Multimedia File playback
 
Multimedia Position:  Indicates the current position of the multimedia file playback.  You can drag this to a new position
 

 Loop Playback:  If this is selected then when the file reaches the end it will begin playback again.  Otherwise it stops
after a single playback

 

 Decrease Windows Volume
 

 Increase Windows Volume
 

 Mutes Windows Volume
 

 Displays the Multimedia sound mixer
 

 Edit the text fields of an MP3 or WMA file (e.g. Artist, Album)
 

 
Controls:

• Menu:  View > Multimedia Controls
• Keyboard: Alt+P (Play/Pause)

 
 
 
Other:

• Overview
• Full Screen Mode

Page 35



• Opening a file in a new file window
• Slideshow and Multishow
• File Information
• Printing Files
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Full-Screen Mode
 
Selecting View > Display Full Screen or pressing space switches to full-screen mode. 
 
In full-screen mode the application is maximized and the title bar, the menu bar and the file selection panels are hidden, so
that you take maximum advantage of your screen size. 
 
Another key has a similar function, 'Ctrl+Space' enables Full-screen mode (if you are not in Full-screen mode already) and 
hides everything bar the image, pressing 'Ctrl+Space' again returns Smart Pix Manager to normal mode.  Double-clicking
the image has the same effect.
 
You can still browse through the current folder or search hits by using the keys or buttons and all normal functions are
available.  You can determine your current position in the folder or media library from the second status bar panel, it will
display the current file number of the total available (e.g. File # 6 of 40 means that currently the sixth file is displayed of 40 in
the folder/media library).
 
There are a number of options available for Full-Screen mode.
 
 
Controls:

• Toolbar: 
• Menu:  View > Display Full Screen
• Keyboard: Space

 
 
 
Other:

• Overview
• Playing Multimedia Files
• Opening a file in a new file window
• Slideshow and Multishow
• File Information
• Printing Files
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Opening a File in a New Window
 
Smart Pix Manager allows you to launch your current file into a new window by selecting View > Open in new window button
or pressing 'Ctrl+N'.  By using new windows you can have multiple files displayed at once and do not need to reload a file if
you return to it later.
 
You can also drag files from the main window and drop them on a secondary window for display.
 
New file windows support most viewing functions of the main window except stretch to fit.  They do not support file
management functions such as move, delete, etc.
 
 
New Window Toolbar
 

 Previous Window:  Will display the previously viewed file window
 

 Next Window: Will display the next file window
 

 Main Window:  Will display the Main Smart Pix Manager Window
 

 Drag Image:  Allows you to scroll an image by clicking it and dragging
 

 Zoom Selection:  Allows you to zoom into an area of your image by selecting it
 

 Zoom in
 

 Zoom out
 

 Word Wrap:  Limits the width of the text to the size of your text window so that you can view it without scrolling
horizontally

 

 File Information:  Displays information about the file such as file size, color depth and dimensions.  It also displays
the keywords and description for the file if it is listed in the media library.

 

 Print File: Prints the file to your printer, automatically selecting an orientation (portrait or landscape) to obtain the
largest picture.

 

 Add File to Favorites:  Adds the displayed file to the current Favorites list.
 

 Add all to Favorites:  Adds the filenames of all open file windows to the Favorites list
 

 Save Settings:  Saves the current settings for Simple Window, Stretch to Fit and Window size as the default for new
windows 
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 Help:  Displays the New Window Help page
 

 Close: Closes this file window
 

 Close All:  Closes all file windows except the main Smart Pix Manager window
 
 
If a multimedia file is loaded you will also see the multimedia toolbar.
 
 
Saving your preferred settings
 

You can save your default settings for window size, 'Shrink to Fit' and Simple Window by right-clicking the file and
selecting, 'Save current settings as default'.  All new windows will use these settings.  However if you have selected
'Resize new image windows to fit image' under Options then your window size settings will be ignored.

 
 
Keyboard Shortcuts for manipulating File windows

 
Ctrl+W or F6 Toggles through all open file windows (including the main window)

Up/Down Cursor Toggles through all open file windows (excluding the main window)

Shift+W Switches to the main Smart Pix Manager window

Ctrl+F4 Close secondary window

Shift+Ctrl+W Close all file windows (except the main one)
 
 
 
Controls:

• Toolbar: 
• Menu: View > Open in New Window
• Keyboard: Ctrl+N

 
 
Other:

• Overview
• Playing Multimedia Files
• Full Screen Mode
• Slideshow and Multishow
• File Information
• Printing Files
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Running Slideshows and Multishows
  
Slideshow
 

The Slideshow function automatically displays your files at specified delay.
 
Start the slideshow by selecting View > Slideshow or "Alt+S"

 
 
Multishow
 

The Multishow displays a slideshow with multiple images on your screen at one time.  You can set the number of images
displayed in Options.
 
Start the multishow by selecting View > Multishow
 
 

Slideshow Toolbar:
 

When activating a slideshow or multishow the following toolbar will be displayed (if you have specified the relevant setting
under options).
 

 Reverse Order:  Displays the files in a reverse sequence
 

 Forward Order:  Displays the files in their displayed sequence
 

 Random Order:  At the end of each file display a new file will be selected at random from those available until each
file has been displayed once

 

 Pause Slideshow:  Pauses the slideshow at the current image or file. Click Pause again to recommence it
 

 Continually Loop slideshow:  The loop button determines what happens when Smart Pix Manager gets to the end of
its files.  If this is not depressed then once the slideshow reaches the first file in reverse mode, the last file in forward
mode or after each file has been displayed once in random mode, it stops.  In other words, enabling loop allows the
slideshow to continue indefinitely.

 
 

 Slideshow Delay:  The slide bar and display allow you to set the delay between file flip.  Please note that this does
not include the load time, i.e. if your delay is 1 sec and your file takes 1 sec to load then in actuality the delay was 2
seconds.

 

 Play background Music:  If you have specified a play list of sound files under Slideshow options then you can enable
playback by depressing this button

 

 Display Transition Effects:  Use the transition effects that you have selected under Slideshow options when flipping
between images

 

 Overlay Filename/Description:  Displays the filename and the description for the file over the image (using your
slideshow text settings in options)
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 Multishow File Count:  If you are running a multishow then you can vary the number of images displayed by clicking
this button

 
 
 
Slideshow Tray Icon and Control Bar:
 

 
During a slideshow an icon is displayed in your system tray area (beside the clock) that you can use to navigate the
slideshow, set ratings, etc.  You can also display a control bar that hovers over all windows (most useful when you are playing
music files and running Smart Pix Manager minimized).  To turn on/off the slideshow control bar, right click the slideshow icon
in the tray area (a green play button) and select "Slideshow Control Bar"
 
 
Other Settings:
 
You can change the delay during slideshow by moving the slide bar, rotating the wheel on your mouse (if you are using a
compatible mouse) or pressing the Comma/Period keys to decrease and increase delay, respectively.  When you are in
full-screen mode you can determine the new delay setting by checking the second status bar panel.
 
You can switch between full-screen and normal mode at any time by pressing space. If you want to tag a displayed file for
viewing or manipulating later, Click the "Add to Favorites" button as it is shown, you can then view all of the tagged files in 
Favorites Mode.
 
 
Note: You can set Smart Pix to automatically run a slideshow or multishow (with the settings of when it was last run) by
using the parameters /SLIDESHOW or /MULTISHOW respectively (e.g. "c:\program files\smart pix manager\smartpix.exe"
/SLIDESHOW).
 
 
Controls:

• Toolbar:    or 
• Menu: View > Slideshow/Multishow
• Keyboard: Ctrl+S

 
 
 
Other:

• Overview
• Slideshow Options
• Playing Multimedia Files
• Full Screen Mode
• Opening a file in a new file window
• File Information
• Printing Files
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File Information
 
You can display the dialog by selecting File > File Information or clicking Alt+Enter.
 
Note: a tool window is also available showing this information in the main window.  Select View > Tool Windows > File
Information
 
 
The following information is displayed:
 
File Information
 

This panel displays general information on the file such as its location, Library status, file size, type, etc.
 
File Attributes
 

These are the system attributes that are assigned to the file (generally by Windows).  You will not normally need to
change these.
 

Keywords
 

If the file is listed in your media library the keywords for the file will be displayed.  You can add or remove keywords by
clicking within the keywords box.  If the file is not yet in your media library you can add it by clicking this box and
confirming the action. 

 
File Description
 

A space is provided for specifying a description for the file.  File descriptions can also be viewed by hovering the mouse
over the file in the main window.  You can search for files with specific text in the description field in Media Library mode.  
 

Rating
 

The Ratings setting allows you to rank your files (you can also use the ratings toolbar).  In Full File Details mode you can
display a ratings column use View > Select Columns > Rating.  You can sort by Ratings using View > Sorting > Sort by
Rating.  You can also filter by the Rating when in Media Library mode.

 
Digital Camera Fields
 

If the image has been retrieved from a digital camera then its embedded (EXIF) data will be displayed (information such as
the date the photo was taken and settings of the camera). 

 
IPTC Fields
 

IPTC fields are data fields that can be stored within JPEG and TIFF images. They are most commonly used by
PhotoShop. You can specify your own data here and it will be saved within the image.

 
Music Fields
 

If you have selected an MP3 or WMA sound file then it may contain music fields. You can view and edit the fields.
Custom Fields
 

The custom fields page allows you to add extra fields to your media library which can be searched in media library mode.
Click "Add" to specify a new field (which will be available to all files in the media library). Then click in the right column
beside the new field to change the text.
 

 
Controls:
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• Toolbar:  
• Menu: File > File Information
• Keyboard: Alt+Enter

 
 
Other:

• Overview
• Playing Multimedia Files
• Full Screen Mode
• Opening a file in a new file window
• Slideshow and Multishow
• Printing Files
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Viewing and Editing MP3 and WMA Tags
 
MP3 and WMA Music files often contain embedded fields that contain such information as the artist name, song and album
title, musical genre, etc.  Smart Pix Manager allows you to edit the tags of an MP3 file by clicking File > File
Information>Music Tags... (WMA file tags cannot be modified)
 
You can also add the Artist and Genre tags as keywords to your media library by clicking 'Add as Keywords..'
 
If you have select multiple files then no tags will be displayed and any tags that you specify will be applied to the selected
images (e.g. if you leave all fields blank except that you set Genre to 'Rock' then all selected files will have their Genre set to
'Rock' and their other fields will not change).
 
You can automate the addition of MP3 and WMA tags as keywords when inserting sound files by selecting the relevant
setting in options.
 
 
Also:

• Playing Multimedia Files
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Printing Files
 
Selecting File > Print.. allows you to print the selected file(s)
 
Print support is provide for:

• Images
• Text Files
• Office and HTML files
• Frames from video files

Note: To print thumbnails select Tools > Print/Export Thumbnail Sheets
 
 
Printing Images:
 

When printing images you have the following options:
• Print Size

This option allows you to specify the output size of the image on the printed page. By default it prints to the maximum
size possible on a single sheet of picture, but if you intend to use your print-outs for photo frames or albums you might
prefer to output at standard photo sizes.
 
The final option allows you to print the image out at poster size. You need only specify the number of pages you want
to use (up to a maximum of 20 pages wide and 20 pages high).

 
• Automatically choose best orientation for printing

If you select this option then Smart Pix Manager will ignore your Landscape or Portrait setting and automatically
choose the orientation that delivers the largest file

 
• Center Image within Page

If you select this option then the image appears in the center of the printed page, otherwise is is positioned in the top
left of the page

 
• Print name and description

If selected, the filename of the image will be printed at the top of the page, and the description at the bottom
 
• Page Margin

This setting allows you to specify what proportion of the page is not used at either the top and bottom or left and right of
the image
 
File printing may take quite a while.  Print time depends on:

• How large the image is.  A small picture prints faster than a large one.
• The speed of your computer and printer, amount of memory, etc.
• The complexity of the image being printed, how many colors it contains, etc.
• The speed of your watch.

 
 

Printing Video Frames:
 

To print a video frame, pause it at the desired location then select File > Print..
 
 
Controls:

• Toolbar:  
• Menu: File > Print
• Keyboard: Ctrl+P

 
 
Also:
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• Other Viewing Information

Page 46



Media Library Functionality Overview
 
What sets Smart Pix Manager apart from other multimedia products is its powerful media library functionality which allows
you to categorize and search the files in your collection. 
 
Review the Media Library mode section for information on searching and filtering your media library.
 
 
For other media library information consult the following sections:
 
Media Library Functionality:

• Adding Files to your Media Library
• Working with Keywords
• Adding Descriptions
• Adding Custom Fields
• Setting the Library Storage Method of your files

 
Maintaining your Media Library:

• Updating your Media Library
• Checking for Duplicate Files
• Media Library Settings
• Maintaining your Source Folders
• Using Multiple Media Library
• Importing and Exporting

 
Advanced Functionality:

• Moving, Copying and Deleting Media Libraries
• Backing up your Media Library
• Using Relative Paths
• Distributing a Smart Pix Media Library on CD/DVD
• Sharing a Media Library on a Network
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Adding Files to your Media Library
 
You can add new files to your media library by selecting 'Library > Add Files to Library Wizard' from the menu.
 
1.  Specify how Smart Pix should look for multimedia files
 

 
 
Either Smart Pix can search for files on your computer or you can specify a particular folder to add.  If the searching
option is used Smart Pix will use a progressive searching algorithm.  Starting first with the most common locations for
multimedia files.
 
Note: Smart Pix will NOT modify your existing files in any way.  Onlystore the location of these files in the media
library (unless you have selected the 'Store files in media library' option)

 
 
2.  Select what formats you want to add
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The second dialog lists your supported formats and allows you to select which formats should be added to the media
library.
 
A list of all the extensions that can be added is displayed (this can be double-clicked for more advanced configuration).

 
 
3.  Confirm your folders
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The third folder lists all the folders that were located with relevant files. You can uncheck those that you do not want to
add (you can also review them in the next step and decide then whether to add them or not).
 
If a "Search for More" link is displayed and you are not happy with the selection that was returned.  Click the link and
Smart Pix will continue searching for relevant folders.

 
 
4.  Add Keywords
 

 
 

As Smart Pix adds each folder to your media library it displays the dialog above showing thumbnails of the files in the
folder and allowing you to add keywords to all the files that it contains.
 
If you do not wish to add the folder click the "Skip" button
 
If you do not want to be prompted for every folder being added, specify the keywords to apply to all the folders, check the
"do not prompt" box and click OK.
 
You can also set Smart Pix to automatically create keywords based on file and folder names, etc, by clicking
"Auto-Keywords"

 
 
Note that as Smart Pix is only storing the location of the files, if you move or delete a file in an application other than Smart
Pix (e.g. Explorer) it will no longer be accessible by Smart Pix (Though you can perform an update to correct this).
 
While the number of files that can be stored in the Smart Pix Media Library is very high, you may experience performance
problems when media libraries get excessively large (e.g. in excess of 100,000 files).  If you have a media library of this size it
is recommended you split your file collection across multiple media libraries.
 
 

 
Controls:
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• Toolbar:  (in Folders Mode)
• Menu: Library > Add Files to Library Wizard

 
 
Also:

• Media Library functionality Overview
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Working with Keywords
 
Keywords are very important in Smart Pix Manager, as they are the primary method for locating and categorizing your files.
 
You can use the following methods to add keywords to files:

• Using the Keywords Tool Window
 

 
Display the Keywords Tool Window using View > Tool Windows > Keywords (if you are using the Simplified interface
option then the menu item is View > Keyword Selector). The keywords of the current file will be displayed in the
uppermost grid.  In the lower grid all your available keywords are given.  To add keywords select them in the lower grid
and click 'Add'.  To remove keywords from the selected file(s) select them in the upper gird and click 'Remove'
 
You can also drag keywords from the tool window and drop them onto the files you want to add them to.
 
Copying and pasting of keywords to/from the clipboard is supported

 
• Add Keywords Dialog

To quickly add keywords to a file click Alt+K, select your keyword(s) and click Enter
 

• Using the File Information Dialog
Display the File Information dialog by selecting File > File Information.  You can alter the keywords for the file by right
clicking the Keywords box.

 
 
 
Editing Keywords

 
To create, rename and remove keywords, click 'Library > Edit Keywords' on the menu or Ctrl+K

 
 
 
Grouping Keywords
 

If you have assigned your keywords to groups you can display them within their groups (as above) by right-clicking a
keyword grid and selecting 'Group Keywords'
 

 
 

Controls:
• Menu: View > Tool Windows > Keywords
• Keyboard: Shift+K (Display Keyword Toolbar), Shift+Alt+K (New Keyword), Ctrl+K (Edit Keywords)
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Also:

• Media Library functionality Overview
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Adding Descriptions to your Files
 
Smart Pix Manager supports the addition of text descriptions to your files.
 
There are two ways to add descriptions:
 

• Using the Description Tool Window

 
Display the Description Tool Window using View > Tool Windows > Description. The description of the current file will
be displayed and you can modify it directly.  To apply your changes to ALL selected files then click 'Set All'

 
• Using the File Information Dialog

Display the File Information dialog by selecting File > File Information.  You can enter the description for the file in the
appropriate box.

 
 
You can search for files with specific text within their description in Media Library mode
 
 
Note: You can also add or append descriptions to existing files using the Import function
 

 
Controls:

• Menu: View > Tool Windows > Description
• Keyboard: Shift+D (Display Description Toolbar)

 
 
Also:

• Media Library functionality Overview
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Setting the Media Library Storage Method
 

Smart Pix Manager supports three ways of listing a file in your media library (plus the option of not being listed).  
 
To see the setting for your files display the field 'Storage Method' in the file grid (You will need to change to 'full file details' by
selecting View > File Details > Full Details).
 
To change the storage method of your files, select the files and click File > Library Storage Method.  You will be presented
the following options:

• No Link to the File(s) within the Media Library
If this option is chosen then the links to all the selected files will be removed from the media library (if they exist).  You
will no longer be able to search for these files within Media Library mode (they will lose their keywords and description)
but you can view them in Folders and Favorites modes.  
 
Note:  You can also quickly remove links of the selected file(s) from the media library by clicking Alt+D

 
• Store Link to the File(s) within the Media Library

This is the default option which adds a link to files (in the current location) to your media library.  This allows you to
add keywords and descriptions to the files and search for them in Media Library mode
 
- Give files a false extension so they cannot be viewed from other programs (Registered Users Only)
 

If checked then images (other formats will be ignored) will be renamed with a false extension (the current default
false extension as specified under Files>Supported Formats), e.g. Images.jpg might be rename image.spm, in this
way the files will be largely invisible to other users/programs.

 
• Store the complete File(s) within the Media Library (Registered Users Only)

This option removes the file(s) from its folder and stores within the encrypted Smart Pix media library.  It offers the
same function as Linking, but improves the security because the files can only be viewed within Smart Pix Manager.
 Whether the original file is renamed to an irrelevant extension or deleted will depend upon your setting under options. 

 
 

Options
 
• Use this as the default storage method for all newly added files

If this option is checked then the option you have specified will be applied to all new files that are inserted into the
media library. You can choose specific options for your different file types by selecting File > Supported Formats

 
• Pause conversion if error detected

If set then Smart Pix will stop every time an image is encountered and advise you.  Otherwise you are advised upon
completion of any errors encountered.

 
 
 
Controls:

• Toolbar: 
• Menu: File > Library Storage Method
• Keyboard: Ctrl+D (Add to Media Library), Alt+D (Remove from Media Library)

 
 
 
Also:

• Media Library functionality Overview
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Updating your media library
 
Selecting 'Library > Update Media Library' from the menu displays the Update dialog.  It is recommended that you regularly
perform media library updates to keep your Smart Pix media library and source folders aligned and to repack your media
library.
 
Update performs three functions:
 
1.  Adds new files
 

The first function is to go through your nominated source folders and check for new files, i.e. files you have copied to the
folder but which are not presently listed in the media library.   These are entered without keywords (in Media Library Files
mode you can highlight these new files by clicking 'Hide assigned files').

 
You can select which source folders Smart Pix should scan for new files:
• Scan all Source Folders

By default Smart Pix will scan all your source folders for new files.  That is, every folder listed in the Source Folders box
will be looked at and if new files are found they will be added.

 
• Scan selected Source Folders

If you do not wish to scan all of your source folders you can select which to scan by setting this option.  Smart Pix will
remember the list of scanned folders in case you want to use the same folders next time. 

 
 
2.  Removes files that no longer exist

 
The second function is to check the folders for any files that have been deleted or moved elsewhere.  If any files
cannot be located they are removed from the media library.

• Ignore files in CD/DVD or network folders that are not available

If you select this option then when Smart Pix cannot locate a folder on a removable drive (e.g. CD/DVD or Zip
drive) or network the files from the folder will be ignored.  If you do not have this option selected you will be
prompted as to whether you want to delete this folder.  It is advised that you leave this option selected as the
most likely cause for the error will be that the CD/DVD is not in your drive, it is sitting on your CD rack.

 

• Ignore files in hard drive folders that cannot be located

If you select this option then when Smart Pix cannot locate a hard drive folder the files from this folder will be
ignored.  If you do not have this option selected you will be prompted as to whether you want to delete this folder.

 
 
3.  Optimize media library files
 

The third function, which is always performed during an update, repacks and optimizes your media library.  The repack
function clears deleted fields from your media library tables, e.g. if you are using media library file storage and you delete
half of your files, the spm_file.blb media library file will remain the same size until you perform a repack.

 
 
Options:

• Update Automatically
The final check box allows you to have Smart Pix perform the update automatically, i.e. without prompting you
before it deletes file listings and adds new files.  

 
 
You can also set up Windows to schedule an update while you are not using your computer.
 
 
Controls:

• Menu: Library > Update Media Library
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Also:

• Media Library functionality Overview
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Checking for Duplicate Files
 
Smart Pix Manager provides support for checking for duplicate files, it can monitor inserted files and compare them with
existing files to ensure that the same file does not already exist (e.g. two images the same but with different filenames). 
 
There are two ways this can be done:

• Automatically (when inserting new files)
If you have set the relevant setting under Options then Smart Pix Manager automatically creates a checksum for the
file and check for any duplicates every time you add a file to your media library.  If a duplicate is found you are
warned and can, optionally, delete the duplicate file.
 
Note:  This process will make file insertion much slower!

 
• Manually

You can also scan for duplicate files at any time by selecting Library > Check for Duplicate Files.  All files listed in
your media library will be checked and you will be advised of any duplicates and offered to delete them.

 
 
Note:  This function is only available in the Registered version.
 
 
Controls:

• Menu: Library > Check for Duplicate Files
 
 
 
Also:

• Media Library functionality Overview
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Media Library Settings
 
The Media Library settings are displayed by selecting 'Library > Settings and Source Folders'.
 
The settings of the currently open media library are displayed:

• Media Library Name: This is the name of the current media library, you can change it by editing the text in this box.
• Location:  This is folder where the media library resides, if you want to change it you will need to use the Media

Library Management tool.
• Owner:  This setting allows you to specify the name of a person or department which may be responsible for the

media library.
• Description:  A short description for the media library can be supplied.

 
 
Access Password (Registered Version only)
 

If desired, you can enable the password on start-up/open option and enter your password.  This function limits access to
the current media library, meaning that without a password it cannot be accessed by Smart Pix or any other media library
application.  Do not forget your password!

 
 
 
Other 

• Read Only
If you want to prevent editing of the current media library you can check the read-only setting.  You will need to specify
a password (this is not related to the access password above) that will be used whenever you want to write-enable the
media library.

 
• Use Keyword Groups to allow Categorization of Keywords

If checked your keywords are listed beneath the group which you have assigned them to.  Otherwise they are displayed
in a single long lists.  You can also change this option by right-clicking any keyword grid.
 

• Convert Storage Method for All Library Files 
Click this option to change the storage method for all of the files listed in your media library.

 
 
 
Controls:

• Menu: Library > Settings
 
 
 
Also:

• Media Library functionality Overview
• Source Folders
• Media Library Options
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Maintaining your Source Folders
 
The Settings and Source Folders dialog (Library > Settings and Source Folders, Source Folders tab) contains a list of all
folders you have nominated as file source folders for the current media library.
 
Some Source Folders may contain special characters. A '%' symbol is a wild card that is generally used to refer to your
CD/DVD drive.  A '$' refers to the Smart Pix Manager program folder.
 
 
Displaying Source Folder Information
 

Clicking on the information button will provide extra details about the selected Source Folder, including the volume name of
the drive and the number of files in the media library from that folder. 

 
 
Adding Source Folders
 

To add new folders click add.  This will take you to the Add Folder dialog.
 
 
Removing Source Folders
 

To remove a folder and its files from the media library (including keywords and descriptions), click Remove (it does not
delete the actual folder from your hard drive only the file listing in the media library)  You can add them back again later by
clicking "Add.." however you will need to re-assign their keywords.
 
If you are using: 
• False extensions for image files:  When you remove this source folder any of its images in the media library will be

renamed to their original names and removed from the media library.
• Media Library File Storage:  When you remove this source folder any files stored in the media library that are

originally from this folder will be extracted from the media library and saved back to the folder.
 

If you wish to remove this source folder but want to retain its files in your media library use the relocate function instead. 
 
Note: when deleting folders in Folders mode Smart Pix will automatically remove it from your media library

 
 
Removing All Source Folders (Purging your media library)

 
If you want to purge all your media library files and start afresh then click on 'Remove All'.  There is absolutely no way to
undo a media library purge, so do not select this option lightly.
 
If you are using: 
• False extensions for image files:  Purging your media library will leave all image files listed in it with your false

extension so you will not be able to view them.  Before deletion you should first convert your storage method back to
Normal, this will rename all files to their original extension.

• Media Library File Storage:  Purging your media library will also delete all files stored in your Smart Pix media
library!  If you want to keep these files but still purge your media library, you should first convert your storage method
back to Normal, this will save all files to their original locations.

 
Relocating Source Folders
 

If you have renamed a folder or moved it from one drive/location to another, you can use the "Relocate" button to point
Smart Pix to the new location of the folder and save you from reloading its files and re-assigning their keywords.
 
If you have moved the folder in Folders mode Smart Pix will have automatically updated your media library listing.
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Editing the Drive Name
 

For each of your Source Folders, Smart Pix stores a drive name, this is used so that when the file cannot be located
Smart Pix can advise you which CD/DVD or other removable device to insert.  By default Smart Pix uses the volume name
of the drive, although when inserting a CD/DVD folder Smart Pix will prompt you for a name for the CD/DVD, if you have the
relevant option set.
 
You can change the drive name for any source folder by selecting it and then clicking the 'Edit Drive Name' button and
entering a new name.  If you wish to rename all drive names for source folders on that drive or CD/DVD then select the
option at the bottom of the dialog. 

 
 
Changing the Default Keywords

 
For each source folder you can specify a set of default keywords by clicking the 'Default Keywords' button and adding
keywords to the list on the right.  Any files that are added to the media library from this folder will be given its default
keywords.
 
 

Wildcard
 
The wildcard value is generally only used when you have received a Smart Pix media library on CD/DVD, or plan to ship a
Smart Pix media library on CD/DVD.  See the 'Using Relative Paths' section for more information.
 
 

Controls:
• Menu: Library > Settings and Source Folders

 
 
Also:

• Media Library functionality Overview
• Media Library Settings
• Media Library Options
• Using Relative Paths
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Using Multiple Media Libraries
 
Smart Pix allows you to create and use multiple media libraries, i.e. have separate sets of file lists and associated keywords
and descriptions for different file collections.
 
For example, you may want to:

• Use Smart Pix for your personal as well as business files, so create a separate media library for each
• Create separate media libraries for each of your image CDs/DVDs.
• Use different file storage methods for different files.  I.e. you might want extra security for private files so use media

library file storage and password access, but use normal storage for your general files 
 
Note that the file collections can overlap between media libraries, you might in fact have them pointing to all the same files,
but have a different set of keywords.  The exception to this is if you are using file media library storage.  Because the file is
stored within the media library, that file is not available to other media libraries.
 
You can create and open media libraries just like a document in a word processor, with one important difference:
 

A Smart Pix media library is not a single file, it is actually made up of many files.  For this reason each media library uses
an entire folder.  That is, you cannot have two Smart Pix media libraries in the same folder.  When you open a media library
you don't locate any particular file, you simply point to the folder that contains these files.

 
 
Creating a new media library
 

Click Library > New Media Library.  You will be presented with the Create Media Library dialog.  
 
All Smart Pix requires is that you give it a name and a folder in which to create it.  It is advised that you create a whole
new folder just for this media library.  
 
I.e. browse to your Smart Pix manager folder and click 'New Folder' to create a new folder.  Enter a name, for example; 'My
Second Media Library'.  Open the new folder and click OK, then OK to the confirmation.  Viola, a new media library is
created.
 
Note: that as two Smart Pix media libraries cannot share the same folder, Smart Pix will warn you if you select a folder
that already contains a media library.

 
 
Opening media libraries
 

Smart Pix provides two ways to open a media library:
• Select Library > Open Media Library and browse to the folder of the media library you want to open (remember Smart

Pix media libraries are not a single file they are a folder of files)
• Select Re-open Media Library and select one of the recently opened media libraries.  Smart Pix remembers the last

four opened media libraries.
 
 
 
Also:

• Media Library functionality Overview
• Moving, Copying and Deleting your Media Libraries
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Importing into your Media Library
 

Importing Media Library Entries
 

Smart Pix supports inputting of media library entries from text files.  
 
Importing is generally used for three functions:
1.  Importing data into Smart Pix from other applications
2.  Restoring backed-up media library information
3.  Batch addition of keywords and descriptions to files.

 
Files should be in the format:
 
File name and path#Description:Description of file#Keyword 1#Keyword 2
 
(in this example a hash symbol (#) is used as a separator but you can use any character as long as you specify it as the
delimit character, see below)
• File name and path : Location of file to be input
• Description(optional): A text description of the file, must be preceded by the word; 'Description:' 
• Keywords(optional):  Keywords to be added to the file, separated by commas

 
For example:
 
C:\my pics\cars\porsche.gif, Description: A red porsche, red, porsche, nice car
D:\anotherpic.jpg
C:\my pics\Japan\Osaka Skyline.jpg#Japanese pics#scenes#cities
C:\my pics\more\PamelaA.png, Description: Beautiful Baywatch Babe
 
Note:  Each record must appear on a single line within the text file!
 
Browse to the CSV that you wish to import and click OK.  You do not need to do any preparation as Smart Pix will create
Source Folders, File references, Keywords and descriptions as required.  
 
 
Importing Keyword Groups
 

When importing a media library file Smart Pix looks for a file of the same name as your import file but with the
extension '.kgr' (in the same folder).  If it finds this file it uses it to create keyword categories and assign keywords to
them.

 
 
Batch Assigning of Keywords and Descriptions:
 

If Smart Pix locates a file being imported that is already in its media library it will assign any listed keywords or
description to that file.  In this way you can use this function to Batch assign keywords and descriptions to your files.
 Simply export your media library to a text file and open it in a spreadsheet, such as Excel, add any keywords or
description to the items and import it back into your media library.  All the new keywords and descriptions will be
added.  
 
Note, however, that this process only adds keywords or descriptions, NO keywords or descriptions are removed!  If
you want the keywords and descriptions of files to match exactly those of the import file then you need to import them
into an empty media library or remove all existing keywords and descriptions on your files before importing (back up
your media library first!).

 
 
Options:
• Do not create for files that cannot be located

If this is checked then Smart Pix will ensure that the file exists before attempting to import it. If it cannot be located

Page 63



then the entry is skipped.
• Append descriptions to existing file descriptions

By default if a description is listed in the import file for a file which already exists in the media library, the existing
description is replaced by the new description.  If you check this item, the new description will added to the existing
description.
 
 

Importing Keyword Lists
 

If you only want to import a list of keywords and/or keyword groups, then you can use the Keyword list import function to
batch insert new keywords.
 
Keywords should be in a single list with one keyword per line.  You can easily create such a list in a text editor such as
Notepad.
 
You can also add the keywords to a specific group by including the group name after the keyword separated by the delimit
character, if you check the box: Keyword entries may include a Keyword Group
 
Example Entry List:

 
Keyword 1#Group 1
Keyword 2#Group 1
Keyword 3
Keyword 4#Group 2
#Empty Group 3

 
 

Delimit Character
• Character used to delimit fields

This is the character that Smart Pix will use to separate fields.  You need to set this to the character that is used to
separate items within each record in the file you are importing, generally this is a comma, or a hash (#) if it was created
by Smart Pix.  If you are not sure what the character used is then open the file with Notepad and check what
characters separates each item.  For example in the following record the delimiting character is a percentage symbol
(%)
 
C:\An Image.jpg%Description: My Favorite car%Car%Blue%Porsche 959

 
 
 

Automating Media Library Importing
 

You can have Smart Pix automatically import a set of media library entries from a text file when it starts up by
passing it the /Import: parameter.
 
For example:
"C:\Program Files\Smart Pix Manager\SmartPix.exe /Import:c:\import.txt"
 
Will run Smart Pix and input the media library entries from the file, C:\import.txt.  Note: that your default import
settings will be used.

 
 

 
Controls:

• Menu: Library > Import and Export..
 
 
Also:

• Media Library functionality
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Exporting your Media Library
 
Smart Pix allows you to export all entries within your media library for using in other applications or for archival purposes.  
Smart Pix exports an entry for each file in your media library and includes all assigned keywords and descriptions.  
 
The file can be imported back into Smart Pix at any time.
 
Please note that the exported file does not include:
• Thumbnails
• Files: If you are using Media Library file storage the export procedure will NOT export the files stored within your

media library
• Custom Fields

 
The above information will be lost if you export a media library and then later import it into an empty media library
 
Note: If you wish to create file lists for specific sets of files or with more information such as image size and color depth,
you should use the Create Lists feature instead.

 
 

Options:
 

• Also export categories to category file
If you are using keyword categories you should set the option to create a category file.  This will create a file of the
same name as your export file, but with the extension '.kgr'.  You should keep this file with your export file. 

 
• Character used to delimit fields

This is the character that will be used to separate fields within each record.  You should set this to a symbol that is not
used in any of your fields, e.g. it is not recommended you set this to a comma, as you may use commas in your file
description and when importing the file into another program it will know whether the comma is a real comma or
indicates a new record.  The default is a hash (#) symbol which is a safe option as you are unlikely to have this symbol
in your media library.

 
 

Controls:
• Menu: Library > Import and Export>Export Media Library Entries

 
 
 
Also:

• Media Library functionality
• Importing Media Library entries
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Overview
 
Smart Pix Manager has the following file management capabilities:

• Renaming
• Moving and Copying
• Deletion
• Setting of the file date and time 
• Launching files in an external editor
• E-mailing Files

 
 
As well as Folder Management Functions and Image Batch Conversion.
 
Smart Pix Manager is completely integrated with Windows Explorer so you can move and copy files or folders by dragging
and dropping them between windows.
 
You can also monitor a particular folder and automatically display any files that are added.
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Renaming Files
 
Files can be renamed by selecting File > Rename or pressing F2.  If you rename a file listed in your media library it will also
change the corresponding listing in the media library.
 
Note: if you have multiple files selected then Smart Pix Manager will prompt you to rename each file in turn (or you may use
Batch Renaming).  You can discontinue this process by pressing Cancel.
 
 
Batch Renaming Functionality:
 

If you select multiple files and choose Rename, the rename dialog will also have a tab for Batch Renaming.
 
Batch renaming will rename all remaining files within your current selection to a specified name followed by a number.  All
files will be keep their current file extension.
 
You need to specify the following details:

• New name :  The text you want to be used for all files, e.g. myimage
• Also add:  Allows you to add the date to the filename (if the image contains digital camera fields, the date that the

photo was taken will be used.  Otherwise the date of the file is used).
• Start numbering at:  Set the number you want to use for the first file.  This number will be increased by one for each

subsequent file.
• Minimum number of digits in added prefix:  Set this at greater than 1, if you always want your file names to have a

set number of digits in their name, e.g. myfile 0001 (4 digits).
For example, if you select the following four files and click Rename 

• An image.jpg
• Another image.jpg
• Mygirlfriend.gif
• LastPix.WMF

 
Then select Batch Rename and enter the text as 'MyImage', leave the other settings to their default, then the images will be
renamed to:

• MyImage 1.jpg
• MyImage 2.jpg
• MyImage 3.gif
• MyImage 4.WMF

 
 
MP3 and WMA Batch Renaming:
 

If you have selected MP3 or WMA music files, and choose the "MP3 and WMA Renaming" tab you can specify a selection
of music fields that Smart Pix Manager should use to automatically rename your files.
 

 
 

Controls:

• Toolbar: 
• Menu: File > Rename
• Keyboard: F2

 
 
 
Also:

• Other File Management Functions
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Moving and Copying Files
 
Selecting File > Move or File > Copy will bring up a dialog box allowing you to move or copy the selected file(s) to a new folder.
 
 
Displaying of Recent Folders or Favorites

 
In the area below the destination folder you are presented with a list of folders to expedite folder selection.  You can
choose whether Smart Pix Manager should display the folders you have most recently moved/copied files to or your list of
favorite folders (from Folders mode).

 
 
Creating new folders:
 

You can create new folders while moving or copying a file by either:
• Typing in a new folder in destination box.  When you go to move the file Smart Pix Manager will confirm that you want

to create this new folder.
• Clicking the 'New Folder' button in the browse dialog.  It will create a new sub-folder in the currently selected folder. 

 
 
Media Library File Reference
 

If the file is listed in your media library you can also specify what Smart Pix should do with the listing:
• Leave File Reference (when moving): The file listing (including keywords and description) will remain with the original

file
• Transfer File Reference:  The file listing (including keywords and description) will be assigned to the destination (new)

original file
• Copy File Reference:  The keywords and description of the old file will be copied to the new file

 
 
Function of move and copy with Media Library File Storage:

 
If you copy a file in media library storage mode the file is created and saved as a normal file in your destination folder.  If
you select Move, it will create the file in the destination folder and delete the file stored in the media library. 
 

 
 

Using Quick Move/Copy
 

The Quick Move/Copy Tool displays a list of favorite and recent folders and allows you to move files simply by
double-clicking on a destination folder.
 
You can display the Quick Move/Copy Tool by selecting View > Tool Windows > Quick Move/Copy (Not available if the 
simplified interface option is set).

 
 

Repeating the Last Move/Copy
 

To move or copy files to the last destination folder you can use the shortcut keys Shift+Ctrl+X (Move) or Shift+Ctrl+C
(Copy)

 
 
Note: You can also move and copy files by dragging and dropping them between Smart Pix Manager and Windows Explorer
 

 
Move Controls:
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• Toolbar: 
• Menu: File > Move File...
• Keyboard: Ctrl+X or Ctrl+M

 
 

Copy Controls:

• Toolbar: 
• Menu: File > Copy File...
• Keyboard: Ctrl+C

 
 
 
Also:

• Other File Management Functions
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Deleting Files
 
You can delete selected files by selecting File > Delete or pressing the "Del" key.  By default you are prompted to confirm the
deletion.
 
File Deletion Options
 

You can turn off Confirmation of Delete under Options.  You can also select whether Smart Pix Manager should move files
to the Recycle Bin upon deletion.  If you want to speed up file deletion you should switch off the option to move files to
the Recycle Bin.
 
If you hold the Shift while clicking the "Del" key Smart Pix Manager will permanently delete the files rather than sending
them to the Recycle Bin.

 
 
 
Controls:

• Toolbar: 
• Menu: File > Delete
• Keyboard: Del (or Shift+Delete to permanently remove files without sending them to the Recycle Bin)

 
 
Also:

• Other File Management Functions
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E-mailing Files
 
Smart Pix Manager allows you to forward files to other people using e-mail.  If you select a file (or files) and click File > E-mail
File, a blank e-mail window will be opened with the files attached so that you can easily forward them to friends and
colleagues.
 
No setup is required within Smart Pix Manager to use this function, however you need to have installed a MAPI compliant
e-mail program on your computer, such as Netscape Communicator or Microsoft Outlook Express.
 
If you have problems using this function please reinstall your e-mail software.
 
 
Image E-mailing Options:
 

Smart Pix Manager offers auto-convert and resize functions for e-mailing of images.  This makes sending and receiving of
e-mails containing images much faster.  You can enable this feature under Options.

 
 

Controls:

• Toolbar: 
• Menu: File > E-mail File(s)
• Keyboard: Shift+E

 
 
 
Also:

• File Functions
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Launching Files to an External Editor
 
Selecting Edit > Open in Editor (or Ctrl+E) will open the current file in the editor that you have specified for this file type in the 
Supported Formats Dialog.
 
If you do not wish to modify the original image use the function Edit > Open a copy of the file in Editor (or Shift+Ctrl+E).
 
 
Note: If you have problems launching into external editors, try changing the option for launching under Advanced Options.
 

 
Controls:

• Toolbar: 
• Menu: Edit > Open in Editor
• Keyboard: Ctrl+E

 
 
 
Also:

• File Functions
• Editing your images
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Folder Management Functions
 
In Folders mode you can perform standard functions on your folders by selecting them and clicking the right mouse button.
 

• Create Sub-folder
This allows you to create a new sub-folder in the selected folder

 
• Rename Folder

This allows you to rename the currently selected folder.  If the folder is a source folder then your media library will
automatically be updated.

 
• Move/Copy Folder

This allows you move or copy the folder to a new location.    If the folder is a source folder then your media library will
automatically be updated.

 
• Delete Folder

This will delete the currently selected folder.  If the folder is a source folder then you will be asked if you want to
remove this folder from your media library.

 
• Add Current Folder to Favorites Lists

This will add the currently selected folder to your 'favorites'.
 

• Add Current Folder to the Media Library
This will bring up the 'Add new source folder' dialog, with the currently selected folder entered.

 
 
Also:

• File Functions
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Monitoring a Folder for Added Files
 
The Watch Folder function monitors a specified folder and displays any files that are added to that folder.  Generally this is
used in tandem with Internet downloading software, such as a newsgroup downloader.  If you set Watch Folder to the folder
where you save your downloaded files, Smart Pix Manager will pop up to show you new files as they are saved in that folder.
 
To start the Watch Folder function, select Tools > Watch Folder.. and browse to the folder you wish to monitor.
 
A check mark will be shown next to the Watch Folder menu item to show you that it is currently monitoring.
 
 
Controls:

• Menu: Tools > Watch Folder
 
 
Also:

• File Functions
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Using the Favorite Folders Function
 
Smart Pix Manager stores a list of your favorite folders and allows you to switch to these folders in Folders Mode simply by
clicking the Favorite folders button and then a destination folder.
 
This list of folders is also used for quickly moving or copying files using the Quick Move/Copy Tool Window and is displayed in
the move/copy dialog box.
 
You can add new folders to the list by selecting them and clicking 'Add Folder'.
 
 
The list can be altered by clicking on one of the following options from the bottom of the favorites list:
 
Update:  
 

This will remove listing to any folders that no longer exist
 

Clear All:  
 

This will delete all items in your favorites list.
 

Edit Folders
 

Allows you to remove specific folders from your Favorites List.
 
 
 
Controls:

• Toolbar:    (in Folders Mode)
 
 
 
Also:

• File Functions
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Overview of Image Editing
 
Smart Pix Manager allows you to perform a number of image manipulation functions:
 
Editing Functions (under the Image menu):

• Rotate or Flip the Image
• Resize the Image
• Crop the Image
• Add text to an image
• Add a border, photo frame or soft shadow to your image
• Merge two images
• Remove the "Red Eye" effect caused by flash photography

 
Effects (under Edit > Color and Effects):

• Manipulate the colors of the image with Filters and Effects
 
Smart Pix Manager also provides a batch conversion function for automatically performing common image manipulations.
 
 
See the Toolbars section to view the Image Editing Toolbar
 
 
 
Also:

• Acquiring Images from a scanner
• Launching an image in an external editor
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Rotating and Flipping Images
 
Selecting Edit > Rotate or Flip Image will display the Transform dialog.  
 
Note: Smart Pix Manager uses a lossless algorithm for JPEG rotation so there is no reduction in image quality.
 
You have three options:

• Rotate the Image:
Select the number of degrees by which the image should be rotated clockwise (any number between 1 and 359), for
example if you select 90 degrees the Top of the image will become the Right of the image.

 
• Flip the image horizontally:

This will create a mirror copy of the original, i.e. the left of the image will be moved to the right and visa versa.
 

• Flip the image vertically:
This will reverse the image vertically, i.e. the top of the image will be moved to the bottom and visa versa.

 
 
Rotating Multiple Files:
 

If you have multiple files selected then you can rotate all of them at once by using the Rotate Left or Rotate Right
functions below...

 
 
Automatic Rotation of Image:
 

Some advanced cameras record the in a digital camera field how the camera was oriented when the photo was taken. 
If your camera supports this then you can automatically rotate all of your images to the correct orientation with the click
of a single menu item.
 
To do this, select all of the files from your camera (do not do this if you have edited them previously) and click Edit >
Other Editing>Automatically Rotate Images...

 
 

 
Rotate and Flip Image:

• Toolbar: (On Image Toolbar)
• Menu: Edit > Rotate and Flip Image
• Keyboard: Ctrl+Alt+F

 
 

Rotate Left:

• Toolbar: (On Main or Image Toolbar)
• Keyboard: Alt+Period

 
 

Rotate Right

• Toolbar: (On Main or Image Toolbar)
• Keyboard: Alt+Comma

 
 
 
Return to:

• Manipulating your images
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Resizing Images
 
The resize function will alter the size of your image.  Unlike zooming, which only changes the displayed size of the image,
Resize will permanently alter the height and width of the image.
 
To display the Resize dialog select Edit > Resize Image.
 
You can set a new image size by altering either:

• The size in pixels of the destination image
• The percentage increase over the original.

 
If you do not wish to maintain the aspect ratio of the image you can deselect the 'Maintain aspect ratio' option and set the
new height and width of image individually.
 
 

 
Controls:

• Toolbar: (On Image Toolbar)
• Menu: Edit > Resize
• Keyboard: Ctrl+Alt+R

 
 
 
Return to:

• Manipulating your images
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Cropping Images
 
If an image has a blank or unwanted area along its edges you can trim it using the image crop. 
 
Note: Smart Pix Manager uses a lossless algorithm for JPEG cropping so there is no reduction in image quality.
 
To crop an image:

1. Select Crop (Edit > Crop Image)
2. Select the portion of the image that you want to keep (everything outside of your selection will be removed).
3. Click OK

 
You can "nudge" the selection rectangle by using the cursor keys (or Shift+Cursor to change the width or height)
 
 
Selection Shape
 

If you click 'Selection Shape' under "Crop Settings", you can specify different shapes to crop the image to. If you chose a
shape other than the default rectangular selection, you will need to specify the color that is used to replace the cropped
section.

 
 
Crop Binding
 

If you select 'Snap selection to..' under "Crop Settings", you can enable the crop binding function. This function causes
Smart Pix Manager to automatically resize the selection to common photo printing sizes when you release the mouse
key.

 
 
Note:  

• Advanced users can crop images by selecting a portion of the image in the main window (Edit >Cursor Action) and
then clicking Ctrl+Alt+X

• If lossless rotation is enabled then the final result may be slightly different than your selection due to the alignment of
JPEG storage blocks.

 
 
Controls:

• Toolbar: (On Image Toolbar)
• Menu: Edit > Crop Image
• Keyboard: Ctrl+Alt+C

 
 
 
Return to:

• Manipulating your images
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Color Effects
 
Smart Pix Manager offers the following Filters and Effects:

• Auto Color Enhance
This function will maximize the of the current image.  You will generally only see a noticeable effect with images that
are very dark or very light.

 
• Adjust Colors

A dialog is displayed which allows you to perform custom color adjustments
 

• Image Effects
A dialog is displayed which allows you perform to custom image effects

 
• Sharpen Image

Makes a blurred image appear more sharp
 

• Grey Scale
Converts the image to grey scale (i.e. as if it were a Black and White photo)

 
• Negative

Creates a negative of the image
 

 
Controls:

• Toolbar: (On Image Toolbar)
• Menu: Edit > Colors and Effects

 
 
 

Return to:
• Manipulating your images
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Removing the Red-Eye Effect
 
When taking photos with a digital camera and flash you will often find that the eyes of your subjects have an odd red color. 
The "Red Eye" tool allows you to remove this effect.
 
Here are the steps:
 
1. Make your selection
 

For a more accurate red eye removal, you should select the area over the eyes.  To do this you need to display the
selection rectangle (Edit > Cursor Action > Rectangular Selection - not available if you are using the Simplified Display
mode) and then click the image and drag the rectangle so that it covers both of the red eyes.

 
 
2. Remove the Red-Eye
 

Click the red-eye button to actuate the removal (click Edit > Undo if you are not satisfied with the effect).
 
 
 
Controls:

• Toolbar: (On Image Toolbar)
• Menu: Edit > Remove Red Eye

 
 
 

Return to:
• Manipulating your images
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Editing Animated GIF's and Multi-Page TIFF's
 
Smart Pix Manager provides an image frame editor, so that you can customize GIF images and edit multi-page TIFFs.  To
use this function, select or create a GIF or TIFF image then select Edit > Edit Animated GIF or Edit > Edit TIFF Pages...  You
can also create an new GIF using File > New>Animated GIF
 
All of the frames of the image will be displayed and you can select frames individually to edit or remove them.
 
 
Functions:

• Frame Settings: Allows you to change the settings of the current frame
• Insert Frame: Inserts a new frame at the current position
• Append Frame: Adds a new frame at the end of the sequence
• Delete Frame: Deletes the selected frame
• Copy Frame Image: Copies the frame to the clipboard for pasting into other applications
• Paste to Frame: Pastes a frame from the clipboard to the current frame
• Load Frame Image: Loads an image from file into the current frame
• Use Frame as Thumb: Sets the selected frame as the thumbnail for this file
• Save Frame Image: Saves the selected frame to a file
• Animate (GIF files only): Animate the current GIF

 
 

Controls:
• Menu: Edit > Edit Animated GIF or Edit > Edit TIFF Pages

 
 
 

Return to:
• Manipulating your images
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Overlaying Text onto your Image
 
This function allows you to overlay text or pictures onto an image. Typically these include descriptions, copyright notices or
company logos.
 
Inserting Text
 

Specify the text that you want included.  You can also include the following tags:
 
%FILENAME% Will be replaced with the filename of the image
%FILEDATE% Will be replaced with the file date of the image
%DESCRIPTION% Will be replaced with the description of the image

 
You will also need to specify the font of the text and whether the text should be given a solid color or transparent
background.
 
 

Inserting an Image
 

You will need to browse for an image that is smaller than the current image
 
 

Insertion Position
 

Specify where the text or image should be inserted. 
 
NOTE: The easiest way to specify a custom position is to select the destination position in the main window (Edit >
Cursor Action > Rectangle Selection) then choose Edit > Edit Edit > Insert Text... This will position the inserted text
starting at the top, left point of your selection

 
 

 
Return to:

• Manipulating your images
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Batch Conversion of Images
 
The Batch Conversion Dialog allows you to automatically convert, transform, rotate or resize a set of images.
 
To use the Batch Conversion Dialog you must first select the images that you want to perform the processing upon, then
select Images>Batch Conversion.
 
You will be presented with the following options:

• Resizing
The Resize option allows you to resize your images depending on the following setting:
 
- None: No resizing is performed on your images
- Resize by percentage: The images will be resized by the specified percentages
- Resize by Dimensions:  The images will be resized to with a maximum dimension of those that you have specified

• Maintain Aspect Ratio of Image Option:

If this is checked then images will always retain their original ratio of height to width.  If you uncheck this
item then the you can freely change the height or width independent of the other dimension.

• Do not stretch images smaller than this size

If this is checked then images and you have specified the desired dimensions then only images that are
greater than this size will be resized. Image that are already smaller than the specified dimensions will be
ignored.

 
• Transformation

The transformation option allows you rotate or transform your images depending on the following setting:
 
- None:  No transformation will be performed
- Rotate Image: The images will be rotated by the specified amount
- Flip Image Horizontally: The images will be flipped horizontally
- Flip Image Vertically: The images will be flipped vertically
 

• Other
Perform automatic color enhancement: 

 
If the image is very dark or very light the colors will be stretched across the normal range to improve color depth.
 Note: This can produce unfavorable results so do not overwrite your originals
 

Sharpen the image:
 
Applies a filter to the images to make them appear less blurry.
 

Set Image color depth:
 
If you need to reduce the number of colors within an image you can use this option to specify a new color depth.

 
Add a border or shadow:

 
Allows you to apply a colored or textured border, or a soft shadow to the images.

 
Apply text or an image:

 
This setting allows you to insert text into every image, e.g. a company name or URL.  You can also insert another
image (such as logo) into your images.

 
 
• Output

You will need to specify the following settings:
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Save Name:
 
- Use Original Filename: If this is selected the changed image will be saved with its original name (thereby overwriting

the original if it is of the same format)
- Add Prefix to Filename:  You will need to specify the text to add prior to the original filename. E.g. if the filename is

image.jpg and your prefix is "Conv_" then the destination filename will be Conv_image.jpg
- Add Numbered Filename in Folder: You will need to specify the base filename, to which an incremented number

will be added. If files of the same name already exist in the folder, then Smart Pix Manager will continue on the
sequence.  All files will be saved to the specified folder

- Save to Folder: Specify a folder where the converted images should be saved to
 
Save Format:
 

The image format that will be used for saving the images. 
 
Generally we recommend you use JPEG format for images that you want to e-mail people, put on your web site or
store on your computer for viewing.  
 
Click the settings button for more control over advanced format settings

Delete Original Image
If this is checked then the original image will be deleted after conversion (if it is not overwritten).  Otherwise the
original image is kept.

 
 
 

Controls:
• Menu: Edit > Batch Conversion..
• Keyboard: Ctrl+Alt+B

 
 
 
Return to:

• Manipulating your images

Page 85



Acquiring Images from a Scanner or Camera
 
Smart Pix Manager supports the acquisition of images from USB and Twain compliant scanners and digital cameras.  To
open the Acquire Dialog box click Edit > Acquire from Scanner/Camera.
 
The process of acquiring images is as follows:
 
1.  Specify the source
 

Your camera or scanner is most likely to be Twain or USB compliant (these specify the way they connect to the
computer).  Newer cameras are USB compliant and appear like a new hard-drive when you connect them.  Older devices
and most scanners are generally Twain compliant. Smart Pix Manager will display a list of all the items that it could detect
connected to your computer. If your camera is not shown ensure it is connected properly and turned on. If that fails you
can use the browse function to locate the device manually.
 

 
2.  Specify the destination folder
 

Specify a folder to which Smart Pix Manager should save the acquired images and, optionally, whether a new dated folder
should be automatically created in the specified folder

 
 
3.  Specify the filename
 

Optionally you can choose for Smart Pix Manager to assign new names to the acquired images.  They will be given a
numbered filename based on the base name that you specify

 
 
4.  Other options

• Insert file into media library
If you set this option the newly created image will be automatically inserted into the media library after a successful
acquisition.

 
• Save format (Twain devices only)

If you are acquiring from a twain device you will need to specify the save format.  The two recommended formats are:

• JPEG format for images you want to view but not edit
• BMP format for images you want to edit

• Delete images from the camera after retrieval (USB devices only)
If this option is specified the images will be moved from the camera to your computer rather than copied.

• Automatically rotate images after retrieval
Many high-end digital cameras set a special field within the image specifying its correct orientation.  Using this field
your images can be automatically rotated for the correct display.  If you check this item then after retrieving images
from your camera you will be prompted to confirm any automatic rotation that needs to be performed.
 

 
 
 
Note: On Windows XP Smart Pix Manager will be offered as an acquisition option when you connect a camera or memory
card to your computer.  You can also add this functionality on other windows version by downloading the camera detection
plug-in from:
 
http://www.xequte.com/smartpix/plugins.html
 
 
 
 
Controls:
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• Toolbar: 
• Menu: Edit > Acquire Images from Camera/Scanner

 
 
 
Also:

• Manipulating your images
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Printing and Exporting Thumbnail Sheets
 
The Thumbsheets Dialog allows you to create or print pages of thumbnail indexes.  To display it select
Thumbnail>Print/Export Thumbnail Sheets
 
 
Choose which files to export information on:
 

• Create Thumbsheets for SELECTED files
If selected then thumbsheets are created only for the selected files

 
• Create Thumbsheets for ALL files in this mode

If selected then thumbsheets are created for all files displayed in the current mode
 
 
• Exclude non-image files

If checked then only images are added to the thumbsheets, otherwise non-image formats are added but only given a
default graphic

 
 
How would you like to export your thumbnail sheets?
 

• Export the Thumbsheets to the following printer:
If selected then the thumbsheets will be printed to the specified printer

 
• Save the Thumbsheets to the following filename stem:

If selected then the thumbsheets will be saved to the specified file, if more than one file is required to export your
thumbsheets then successive pages will be given an incremented filename, e.g. if your first file is mythumbs.jpg, then
the second will be mythumbs2.jpg, then mythumbs3.jpg..)

 
 
Settings

 
• Heading

Specify the text that is added to the top of each page
 

• Number of thumbnails per page
These setting will determine how many thumbnails are placed across (horizontally along the image) and down (placed
vertically down the image) the page .  The higher the setting the more thumbnails will be displayed but the smaller they
will appear.

 
• Resolution of the image (when saving)

This determines the size of the image (in pixels) that will contain your thumbnails.  A good choice is to set this to the
size of your screen.  (most screens are 800 or 1024 pixels wide and 600 or 768 pixels high)

 
• Colors

Allows you to specify the background and text colors for the thumbsheet
 
 
 

Advanced Settings
 

If you click the advanced settings button you will be given the following extra options:
 

 
Heading:
• Specify Heading Font Size

By default Smart Pix Manager determines the size of the font by the available space.  If you prefer you can specify a
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point size.
 
• Append the Page Number to the Heading

If you want the page number to be appended to the heading (in the format ',page x') then select this option
 
 
Filename Display:
• Filename Position

Allows you to specify whether the filename for the thumbnails should be shown, and if so, above or below the thumbnails
 
• Specify Filename Font Size

By default Smart Pix Manager calculates an appropriate font size based on the average width of your filenames.  If you
prefer you can specify a point size.

 
• Hide Filename Extensions

If checked the file extension will not be displayed, e.g. "Image" will be shown for the file "Image.jpg"
 

 
Other:
• Page Margins:

This setting allows you to specify what proportion of the page is not used at either the top and bottom or left and right of
the image

 
• Thumbnail Border

Allows you to specify a border that will be added to your thumbnails
 

• Thumbnail Shadow
Adds a shadow to your thumbnail of the specified color

 
• Background Image

Allows you to select an image that will be tiled onto the background of your thumbsheet
 
 

 
Controls:

• Menu: Tools > Print/Export Thumb Sheets
 

 
 

Also:
• Overview
• Print or export file details
• Create a web site (HTML pages) from your files
• Create Auto-Playing Slideshow CD/DVD Disks
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Printing and Exporting File Lists
 
The File List Dialog allows you to export details on your files to a text file or to a printer.  To display the File List Dialog select
Thumbnail>Print/Export File Information
 
 
Choose which files to export information on:
 

• Export information on SELECTED files 
This option creates a file list for all files that you have selected

 
• Export information on ALL files in this mode

This option creates a file list for all files that are displayed in the current mode
 
 
How do you want to export your text list?
 

• Export the File List to a Printer
This option prints the created file list to your printer

 
• Save the File List to the following file

This option saves the created file list to the specified file. Supported output formats are Text, CSV, HTML or XML
 
 
Export Fields
 

These are a list of all the fields that can be exported.  Check those fields that you want to export.  You can also reorder
the fields using the Up and Down buttons

 
 
Include header row with field titles
 

If this option is set then a row will be added to the top of the file list containing all the fields names
 
 
Separate fields with the character
 

This option allows you to specify the character that is used to delimit the fields within the export list.  Some programs
require this to be a comma.  However a infrequently used character such as hash (#) is generally better.

 
 
 
Controls:

• Menu: Tools > Print/Export File List
 
 

Exporting File Lists for Diji Album Editor
 

You can create a list of filenames and descriptions to import into Diji Album Editor. You will need to install Diji Album first
from:
 
http://www.xequte.com/dijialbum/
 
Then follow these steps:
 
1. Select the files to export in Smart Pix Manager (if you wish to maintain a specific order then add them to your Favorites

list and reorder the list)
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2.  Select Tools > Other>Add Files to Diji Album Editor (This options is only Diji Album can be located on your system.  If
you did not install Diji Album to the default folder and the entry does not display then will need to reinstall Diji Album).

3.  Run Diji Album Editor 
4.  Select Page > Import Pages Wizard

 
 
 
Also:

• Overview
• Print or export pages of thumbnails
• Create a web site (HTML pages) from your files
• Create Auto-Playing Slideshow CD/DVD Disks
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Creating Web Page Image Indexes
 
The Web Page Creation Wizard (Registered version only) allows you to create an HTML thumbnail index for all files in the
current mode.  These can either be used as an index to files on your computer or to publish your images on the Internet.
 
To display the Web Creation Wizard select Tools > Web Creation Wizard
 
Note: If you are uploading to a UNIX web server where case sensitivity is important, select the 'Force lowercase' setting in
Advanced Options.
 
 
Here is a summary of each step of the wizard:
 
Step 1: Choose which files to include
 

Specify whether all files in the current mode should be included in your thumbnail index, or just the selected files.
 
Also select whether to only include image or all file types.

 
 
Step 2:  Specifying Save location
 

Specify the folder where the Web index should be created.  All HTML, images and other required files will be copied to this
folder so that you can easily publish it to the Internet
 
Also you will need to specify the name of the first HTML file

 
 
Step 3:  Page Layout
 

Allows you to specify the layout of the created pages and whether descriptions are displayed.
 
 
Step 4:  Page Style
 

Displays a selection of pre-built styles. Select your preferred style, or choose the custom option to specify your own style
settings

 
 
Step 5:  Other Options 
 

This step provides optional settings for customizing your HTML Page:
 
• Heading

 Specify the heading to display at the top of each page
 

• Add a link to your home page
If you would like to add a link to your home page or other file at the bottom of each page, then select this option.  You
need to provide two values:

- The text for the link, e.g. 'Back to Home Page'
-The actual link.  This will generally be a HTML file name such as 'Index.htm' (if it is in the same folder as the

Thumbnail indexes), but any can be any HTML supported link, e.g.
/C:\Windows\Black Thatch.bmp
http://www.xequte.com/
../home.html
./about/aboutme.html

 
• Do not display filenames
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By default, beneath each thumbnail is the filename of the image. If this item is checked the filename is not added
 

• Add Link to Xequte web site
Specifies that a small link to Xequte is added to the bottom of each page.

 
• Use custom images for your navigation links:

If you select this option then you can specify images to use for the Previous Page, Next Page and Slideshow links.
 Otherwise a text link is used

 
• Show visible grid between rows and columns

By default the grid holding the thumbnails is not visible, if this option is selected a grid is displayed
 
 

Step 6:  Thumbnail Options
 

• Number of Thumbnails
Allows you to specify how many rows and columns of thumbnails are displayed on each index page. If there are more
files than will fit on one page then Next/Previous links will be added.

 
• Maximum thumbnail Size

These settings allow you to specify the maximum dimensions of the thumbnails.  As the image aspect ratio is
maintained, images will generally be narrower or shorter than the value you set here.

 
• Thumbnail JPEG quality setting

Specify the quality setting for your JPEG thumbnails.  This does not need to be as high as you would normally use
because the thumbnails are small so image degradation is not as noticeable.  A setting of 60 - 70% is recommended.

 
 
Step 7:  Image Options
 

Web browsers can generally only display JPEG and GIF type images, so it is recommended that you convert all images to
this format. You can also choose to resize images that are over a certain size, so that they fit on screen and load faster.
 
Note: Typical screen size is 1024x768 pixels

 
 
Step 8:  Image Slideshow
 

This setting allows you to add a slideshow page to your thumbnail index. If users select this page then images will be
displayed in sequence at the specified delay. You can also choose to use transitions as images flip one to the next (Note:
some browsers do not support transitions and will only flip the images normally). You can add a sound file to play in the
background.
 
 
 

Controls:
• Menu: Tools > Web Page Creation Wizard

 
 

 
Also:

• Overview
• Print or export file details
• Print or export pages of thumbnails
• Create Auto-Playing Slideshow CD/DVD Disks
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Create Slideshow CD and DVD Disks
 
If you want to share images and videos with your friends and family then Slideshow Disks are one of the best ways to do it.
 Slideshow Disks, particularly when using DVD disks, can hold hundreds of images and will auto-play when they are inserted
into a PC (without needing to install any software).  Background music, captions and transitions effects are fully supported.
 
Note: For more powerful slideshow disk creation, including creation of disks for playback on DVD players you should
evaluation DVD PixPlay:
 
http://www.xequte.com/pixplay/
 
 
 
Here are the steps to creating a Slideshow Disk:
 
 
1.  Select your Files
 

In the main window select the files that you want to add to the CD.  If the files are in multiple folders or you want them
displayed in a particular order you should add the files to favorites (File > Add to Favorites) and then make your selection
in Favorites mode (you can also re-order your files in Favorites mode using drag and drop).
 

 
2.  Display the Slideshow Wizard
 

Select Tools > Create Slideshow CD/DVD.  Follow the steps to choose what files to use and whether to burn the
slideshow files directly to a disk or output them to a folder (so you can use your preferred CD writing software to output to
disk).
 
Specify the settings and style for the slideshow.
 
Create a title page that will be displayed at the commencement of the slideshow
 
Specify any text to display over the images while they are being displayed
 
Resize and convert the images if required to reduce their size (so they load faster and you squeeze more onto a disk)

 
 
3.  Burn the Slideshow to Disk
 

Insert a blank CD or DVD disk and follow the remaining steps to output the files
 
 
 
Controls:

• Menu: Tools > Create Slideshow CD/DVD
 
 
Also

• Overview
• Print file details or Save file details to a text file
• Print pages of thumbnails or save pages of thumbnails to an image file
• Create a web site (HTML pages) from your files
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Options Overview
 
Smart Pix Manager offers a large number of settings that can be customized to your requirements.  These can be a little
confusing at first so please read the relevant section within this Help file before enacting changes that you are unsure of.
 
Click the relevant link below for further information on that option tab:

• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options

 
 

 
Controls:

• Menu:  Tools > Options
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Interface Options
 
User Interface

• Simplified User Interface
This option reduces the complexity of Smart Pix Manager by hiding many of the advanced functions, such as:

-Reduces file display modes to Large Thumbnails and full details
-Hides all toolbars except the main and multimedia (when shown multimedia files) toolbar
-Displays the simplified format selector (File > Supported Formats)
-Hides many other 'advanced' menu items
 

This option is recommended for users who have little experience with Smart Pix Manager and/or computers.
 

• Message Beeps
Smart Pix Managerwill beep if an error is encountered (e.g. when a file cannot be deleted)

 
• Main Screen Layout

Specify the layout of the Smart Pix Manager main window. 
 
 
Style

 
• User Interface Style

Specify the styling of the buttons and toolbar from common styles such as Windows or Office XP
 

• Style of Mode tabs
Choose whether an image and/or a caption should be displayed on the mode tabs

 
• Image background

If you do not want to use the default image background colors (Black in the Main Window and Navy in New Windows)
then select this option and choose a new color (or two colors for a gradient fill)
 

 
  
Folders Mode Startup Folder
 

Specify whether Smart Pix Manager defaults to a specified folder on start-up or remembers the folder that you were using
when you last closed it.

 
 
 
 

Option Tabs:
• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• Media Library Options
• Other Options
• Advanced Options
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Display Options
 
File Display

• Hide file extensions
If this option is set then filename extensions are not displayed (e.g. myimage.jpg will be displayed as myimage)
 

• Hide System Files
If checked then Windows system files are hidden from display

 
• Hide Hidden Files

If checked then files that are set as 'Hidden' are hidden from display
 
• Hide Shortcut Files

If checked then Windows shortcut files are hidden from display
 

 
 
Full-Screen Mode
 

You can display a file full-screen by selecting View > Display Full Screen.  The following settings control full-screen
functionality:
• Hide main toolbar and status bar when in full-screen mode

By default, even in full-screen mode the main toolbar and status bar are shown (you need to double-click on the image
to hide them).  However, if you check this option then they will hidden in Full-Screen mode (you can still display them
by moving to the top or bottom of the screen)

 
• Hide Tool Windows in full-screen mode

If this option is set then your Tool Windows (description, Quick Move, mixer, etc) are hidden when activating full-screen
display

 
• Display slideshows full-screen 

If this option is set then when commencing a slideshow, full-screen mode is activated
 

• Always display images launched from Explorer Full-Screen
When launching images from Explorer or other application, by default, they are only displayed normally.  If you check
this option then Smart Pix Manager will always open in full-screen mode to display them

 
 
 
Other
 

• Play audio files associated with the displayed image
Automatically plays a sound file (MP3, WAV or WMA) of the same filename as the displayed image

 
• Automatically display camera photos with correct rotation

When you take a portrait photo many digital camera will store the orientation information in the image fields.  This
information is used to display your images at the correct orientation

 
• Launch large Multimedia files to the Windows default viewer

If selected then video or audio files that are larger than the value specified will be launched to their default windows player
 
 
 
 

Option Tabs:
• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
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• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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Thumbnail Options
 
Thumbnail Display Size
 

Allows you to specify the size of the thumbnails that are displayed in the Thumbnail file display mode:
 
- Thumbnail Size: The size of thumbnails when the standard Thumbnails display option is specified (If the small

thumbnails option is selected then the thumbnails will be half this setting)
- Large Thumbnail Size: The size of thumbnails when the Large Thumbnails display option is specified.  Note this size

thumbnail is not saved to the disk cache so will be much slower
 
 
Thumbnail Disk Cache

• Disk Cache Size:
Memory and Disk Caching is used to speed up the display of thumbnails in this application.  Memory caching is set
automatically and only affects your system while Smart Pix Manager is running.  Disk Caching saves a copy of the
thumbnail to your hard drive (typically it takes up about 2-3 KB per file).
 
You can specify the maximum number of thumbnails to be stored on your system by setting the value here.  A low
value will mean that less hard disk space is used, but display will be slower.  A high value gives the best performance.
 Smart Pix Manager will automatically delete old thumbnails if the number is larger than you have specified here.

 
However, if you set the 'Unlimited Storage' option then no thumbnail will be deleted until you click the 'Clear Cache'
button

 
• Clear Cache

Click here to clear all the thumbnails from your memory and disk caches
 

 
 

Media Library Thumbnail Storage
 

Generally you will not require Media Library Thumbnails as Smart Pix caches thumbnails on your hard-drive.  With
removable devices (such as a CD, DVD or Zip disk), you may prefer to always save a thumbnail within the Smart Pix
media library, so that you can view thumbnails for images even if they are not available, i.e. when the removable device is
not inserted

 
 
 
 

Option Tabs:
• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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Slideshow Options
 
Slideshow Settings

• Display Slideshow Toolbar
During a slideshow a toolbar is displayed which allows you to set the direction and delay of the slideshow

• Display File information over the image 
The filename, description or other information will be overlaid onto the image while the slideshow is running

 
• Play Background Music during Slideshow

Select music files to play while a slideshow or multishow is in progress
 

• Display Image Motion Effects
As each image is displayed it is panned or zoomed to give the effect of motion

 
• Image Transition Effects

Use transition effects to enhance the display as you flip from one image to another
 
 
 
 
Multishow Settings

• Highlight current Multishow Image
The most recently displayed image in a Multishow is displayed with a red border

 
• Number of images:

Specify the number of images you want displayed Vertically (side-by-side) and Horizontally (top-to-bottom) during a
Multishow

 
 
 
Default Settings
 

Note:  These settings can also be changed by using the slideshow toolbar
• Order of File Display:

Specify the order of the slideshow:
 

- Backward:  The slideshow will progress in reverse order
- Forward:  The slideshow will progress in their displayed order
- Random:  At the end of each file display a new file will be selected at random from those available until each file has

been displayed once
 
• Delay before displaying next file:

Specify the number of seconds pause between files being loaded
 
• Loop Slideshow Indefinitely

The slideshow will not stop when the last file is reached, rather it will restart display from the beginning
 
 
 

Option Tabs:
• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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File Function Options
 
File Management
 

These options determine the level of confirmation that is required when performing file functions
• Confirm deletion of files

If this is set then Smart Pix Manager will ask you to confirm before deleting any files
 
• Confirm all file drag and drop actions

If selected then when you drag files onto Smart Pix Manager, it will prompt you for confirmation for all actions other than
image display

 
• Confirm move/copy when using the Quick Move function

If you select View > Tool Windows > Quick Move you are displayed the Quick Move tool that allows you to move or
copy files just by double-clicking a folder.  If you select this option then you are always promoted to confirm such
moves.

 
• Move files to the Recycle Bin on deletion

If this is set then when deleting files Smart Pix Manager will move them to your Recycle Bin, if not set then files will be
permanently deleted

 
 
 
Renaming Clashed Files
 

This option allows you to specify the default text added to file name when offering to rename a file because the same name
already exists (e.g. when moving or copying files)

 
 

 
JPEG Settings
 

JPEG images are compressed to that they take up less disk space.  By default Smart Pix Manager will not prompt you for
a JPEG setting, it will use the default.  You can specify your default JPEG Quality setting here.  A high value will be better
quality, whereas a lower value will require less disk space
 
• Always use this setting when saving JPEG's

If selected then when saving a JPEG file you will not be prompted for a JPEG quality setting, your default value will
always be used

 
 
 
Option Tabs:

• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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Media Library Options
 
Media Library Settings

• Confirm addition of files to media library
If this is checked then whenever new files are added to the media library indirectly (i.e. when adding keywords or
descriptions to a file that does not already exist in the media library) then you will be prompted to confirm the insertion.
 You are never prompted when inserting by normal means such as using the 'Add Files to Library Wizard'

 
• Confirm addition of new source folders

When you add a file to your media library, and the folder of the file has not been added to the media library, this option
determines whether you are prompted to confirm the addition and/or specify an alternative folder

 
• Prompt for a drive name when adding new source folders

If enabled then when adding new source folders from a CD/DVD Smart Pix will prompt you for a drive name to use for all
folders on the CD.  If not selected then Smart Pix will use the volume name for each drive and CD/DVD (you can
change the drive name later under Source Folders)
 

• Settings and Source Folders of Current Media Library
Clicking this will display the Media Library Settings and Source Folders dialog.

 
 
 
Automatic Keyword and Description Generation

• Add the folders within filenames as Keywords
If this option is checked then all the folder names within a filename will be added automatically as keywords.  For
example if you are inserting the image:
 
C:\Car Pictures\Porsche\Racing\Boxster.jpg
 
Then the image, Boxster.jpg, will be given the keywords, Car Pictures, Porsche and Racing.

 
• Add the words within filenames as Keywords

If this option is checked then the words within a filename will be added automatically as keywords.  For example if you
are inserting the image:
 
Porsche Racing Boxster 2.jpg
 
Then the image will be given the keywords, Porsche, Racing and Boxster.

 
• Add Artist and Genre Tags from MP3 and WMA files as Keywords

MP3 music files generally contain tags which give such information as the Artist, Song Title, Musical Genre, etc.  If you
check this option then when inserting MP3 and WMA files into your media library, Smart Pix will read the Artist, Album,
Genre and Year tags and add them as keywords to your media library

 
• The creation (photographed) date of the file

If true, then the month and year are added as a keyword to the file, e.g. a file of the date 1/15/05 will have "January
2005" added as a keyword
 

• Exposure time and Camera (Digital Camera Images)
If checked then Smart Pix will add the following digital camera (EXIF) fields as keywords: camera make and model,
exposure time and flash mode

• Embedded IPTC (PhotoShop) keywords and descriptions
If checked then Smart Pix will check for PhotoShop descriptions and keywords when inserting images and add them to
the media library

 
 
 

Duplicate File Checking
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Smart Pix Manager supports Duplicate File Checking, it can monitor inserted files and compare them with existing files to
ensure that the same file does not already exist (e.g. two images the same but with different filenames).
• Check for identical files when inserting a new file

If this is checked then whenever a new file is inserted into the media library, it will be compared with other files in the
media library to ensure that an identical file has not already been inserted

 
• Rebuild Checksums for All Files

Smart Pix Manager stores the checksums for your files within its media library to make the checking for duplicates
much faster.  It will automatically recreate checksums if it knows that a file has changed, however you may want to
recreate checksums if modifications to files have been performed in other applications

 
 
 

 
See Also:

• Media Library Performance Options
• Settings of the Current Media Library

 
 
 
Option Tabs:

• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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Other Options
 
Sending E-mail
 

Smart Pix Manager allows you to e-mail files by selecting them and clicking File > Email File(s).  When you e-mail
images such as those from a digital camera you may find they take a long time to send or that your friends complain that
it takes too long to download.  This is because the disk size of an image can be very large, either because the dimensions
(width and height) are big, because it was not compressed enough or because some formats, such as BMP, do not
support compression.
 
Smart Pix Manager addresses this by giving the option of automatically converting the images to JPEG when sending.
 Your original images will not be affected, a second set of optimized images is created and sent.
 
Options:
• Only when the image is greater than x KB

If you check this option then images are only converted if they are greater than the specified size
 

• Reduce size to..
If this option is set then the dimensions (width and height) of the images will also be reduced during the conversion.
 This will help reduce their disk size and make sending faster

 
 
 
Zip Support
 

Smart Pix Manager allows you to browse the contents of Zip files in the same way that you can browse file folders if you 
install the Zip Plug-in.  This includes support for encrypted Zip files. 
• Remember my Password

If your zip files are encrypted then you can specify that Smart Pix Manager use a default password when opening
them (if the password does not match then you will be prompted to supply another)

 
 
 
Miscellaneous

• Pre-loading of Images
To speed up the display of images you can set the program to pre-load the next image while you are viewing the
current one.  It will be loaded in the background so when you choose to display it can be shown instantly.
 
Smart Pix Manager uses your previous action to determine what you will do next, for example if you clicked the Right
arrow, then it assumes you will click the right arrow next time and pre-loads the next file.  It does the same for left
clicks and selection of random images.
 

• Navigate files using the Wheel Mouse
Override the default handling of the mouse wheel (scrolling windows and zooming images) so that it navigates to the
previous/next file

 
• Store descriptions in IPTC field for JPEG Images

Any descriptions you add to JPEG images will also be embedded in the IPTC field of the image (allowing other
applications to easily access them).  You can also manually write your descriptions to a selection of files by clicking
Ctrl+Alt+I

 
• Redisplay all Usage Tips 

Enable all the warnings that you have previously chosen to not display again will be re-displayed when appropriate
 
 
 
Advanced Options
 

Click the Advanced Options button to edit advanced and miscellaneous settings of Smart Pix Manager.
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Option Tabs:
• Interface Options
• Display Options
• Thumbnail Options
• Slideshow Options
• File Function Options
• Media Library Options
• Other Options
• Advanced Options
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Advanced Options
 
The Advanced options dialog can be displayed by selecting Tools > Options, Other tab and click 'Advanced...'
 
Media Library Performance Settings:
 

If you are using Smart Pix with large media libraries (in excess of 20,000 file records) you may find that the default options
make Smart Pix sluggish.  Setting the following options will significantly improve performance:
• Limit caching of display records

Smart Pix caches the entire set of display records (i.e. all records of files in the current media library) in memory to
allow full sorting, grouping and faster navigation. However with very large media libraries, this may cause Smart Pix
Manager to load very slowly.  To speed up loading select this option and choose a smaller record cache size such as
2000 records.
 
Note: If you disable caching of all records then you will only be able to sort on the following fields when in Media Library
mode:  Filename, Path, File Type, Windows Type

 
• Cache all records when performing media library searches

If checked, then the cache is not limited when performing searches on media library files (do not use this option if your
searches generally return more than 2000 files)
 

• Do not display all media library files, only allow searches
If this option is selected then Smart Pix does not display its entire media library by default in media library mode. Users
will only be able to view the media library by performing a keyword or description search. This option is only
recommended for extremely large media libraries or media libraries accessed over a slow network

  
 
 
 
Other Media Library Settings:

• Always check correct CD/DVD is inserted
If this is true and a file is missing from a CD/DVD then it is actually checked first to ensure that it is the correct
CD/DVD before announcing that it needs to be inserted

 
• Share access to Smart Pix Media Libraries (lowers performance)

By default Smart Pix is optimized for single access to its media library which gives improved performance.  If the media
library you are accessing is shared then check this option.  

 
• Display error thumbnail for files that are unavailable

If you are using saving your thumbnails in the Smart Pix media library, then, by default, a thumbnail is displayed even
for images that are not available (e.g. on a CD/DVD that is not inserted).  However if you check this item, a special
thumbnail (featuring a '?') will be displayed for missing files instead.

 
 
 

 
Thumbnail Loading

• Don't load thumbnails for images larger than x MB
Creating thumbnails for very large images can slow down the browsing of files.  This option allows you to disable the
thumbnailing of very large images to speed up browsing
 

• Don't load thumbnails for videos larger than x MB
Generating thumbnails for videos can slow down the browsing of your files.  This option allows you to disable the
thumbnailing of very large images to speed up browsing

 
• Load Explorer Thumbnails for:

Allows you to specify particular formats for which Smart Pix Manager retrieve the thumbnail from Windows Explorer
for, typical formats for this are AVI and MPEG
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Other Options

• Delay loading of full image until required
Speeds up the display of JPEG images by optimizing the loading to match the zoom level (e.g. for an image at less
than 50% zoom it only loads half of the available JPEG pixels)
 

• Do not modify the file date when editing and saving
By default, Windows will modify the date of files when you save them, if you select this option then your files will keep
their original date even if you edit or save them in this software
 

• Use Lossless rotation and cropping for JPEG images
Specifies whether JPEG images are rotated and cropped using a lossless (no image quality is lost) or lossy (some
quality will be lost upon saving) routine

 
• Force lowercase for links and references when creating HTML

If you are uploading thumbnail indexes created in this program to a UNIX web server (which are case sensitive), it is
recommended that you force lowercase references and set all files to lowercase as you upload them
 
 
 
 

Also:
• Options Overview
• Other Options
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Supported Formats Overview
 
Supported Formats dialog
 

The Supported Formats dialog allows you to specify which file types should be displayed within Smart Pix Manager and
what method should be used to display and edit them.  You can display the Supported Formats dialog by selecting Tools
> Supported File Formats 
 
Smart Pix Manager categorizes all of its files into 7 types:
 
Image Files:  These are all common image formats
Video Files:  These are video files supported by Smart Pix Manager
Sound Files:  These are sound files supported by Smart Pix Manager
Common Windows Files:  These are Office, Adobe Acrobat and HTML files that are supported by Smart Pix Manager
Text Files:  These are plain text and rich text files
Custom formats:  These are formats that you have specified that Smart Pix Manager should include
Other:  These are all files that do not fit into the above categories
 
For further information on Smart Pix Manager's supported formats and expanding them view the Supported Formats List
 
You can specify whether to include or exclude each category by checking its item
 
You can control further details for each category you have selected by clicking on the tabs:
 
• File Extensions

This the list of file extensions for each file type.  You can add extra formats or block certain formats within each file type
by clicking the 'Select Button'
 

• Single-Click
This is your setting for the Standard Display Method for each file type, that is, what happens when you click upon that
file type
The following settings are available:
 
- Ignore (do not display):  The file will not be displayed (though you can still select it for moving, copying, deleting, etc).
- Use Windows Default Program:  The file will be launched into the default program associated with it in Windows (Do

not use this option if Smart Pix Manager is associated with the file type!) 
- Display with Specified Editor:  The editor that you have specified for the file type under the Editor tab will be used to

display the file
- Display with Smart Pix Manager *:  Smart Pix Manager displays the file
- Display Full-Screen in Smart Pix Manager *:  Smart Pix Manager goes into full-screen mode and displays the file
 
* Only available if Smart Pix Manager supports the particular file type internally
 

• Double-Click
This is your setting for the Extended Display Method for each file type, that is, what happens when you double-click
upon that file type
 
The following settings are available:
 
- Ignore (do not display):  The file will not be displayed (though you can still select it for moving, copying, deleting, etc).
- Use Windows Default Program:  The file will be launched into the default program associated with it in Windows (Do

not use this option if Smart Pix Manager is associated with the file type!) 
- Display with Specified Editor:  The editor that you have specified for the file type under the Editor tab will be used to

display the file
- Display with Smart Pix Manager *:  Smart Pix Manager displays the file
- Display Full-Screen in Smart Pix Manager *:  Smart Pix Manager goes into full-screen mode and displays the file
 
* Only available if Smart Pix Manager supports the particular file type internally
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• Editor
This allows you to specify your preferred editor for each file type.  When you click Ctrl+E the file will be launched into
the specified editor
 

• Media Library
This allows you to set the default method of media library storage for each file type.  Click here for more information on
the Library Storage Methods.
 

• Associations
The term associations refers to the program that Windows uses to display a particular file type.  E.g. if *.jpg files are
associated with Smart Pix Manager then when you click on a *.jpg file in windows then Smart Pix Manager is loaded to
display the file.
 
Click the 'File Associations' button to select the formats that are associated with Smart Pix Manager.  

 
 
 
Multimedia
 

You may be able to expand the formats available to Smart Pix Manager by clicking the 'Expand' button.  This will poll all
the formats of Smart Pix Manager and check whether the format is available but not registered with windows.

 
 
 
Controls:

• Menu:  Tools > Supported Formats
 
 
Also:

• Supported Formats List
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Supported Formats
 
Smart Pix Manager can support the following formats:
 
Note: Support for each format can be configured in the Supported Formats Dialog (If you are using the Simplified Interface you
will not be able to access all configuration options)
 

• Image formats:
Bitmap (*.bmp, *.rle, *.dib), JPEG (*.jpeg, *.jpe, *.jpg), JPEG2000 (*.jp2, *.j2c, *.j2k, *.jpc), Standard and Animated
GIF (*.gif), XJPEG 128bit AES Encrypted JPEG (*.xjpeg, *.xjpg, *.xjp), Paintbrush (*.pcx), PNG (*.png), Single and
Multi-Page TIFF (*.tiff, *.tif, *.g3n, *.g3f), Paintshop Pro (*.psp, *.pspimage), PhotoShop (*.psd, *.pdd), Icons
(*.ico), Cursors (*.cur), Metafiles (*.emf, *.wmf), Kodak Photo-CD (*.pcd), Dicom Medical Imaging Format (*.dcm,
*.dicom), Alias Wavefront RLE (*.pix), Apple Pict (*.pict), AVS (*.avs), Dr. Halo (*.cut, *.pal), FITS (*.fits), FlashPix
(*.fpx), GFI Fax (*.fax), Gimp Image (*.xcf), Graphviz DOT (*.dot), HDF (*.hdf), HP PCL Printer Image (*.pcl), JBIG
(*.jbig, *.jbg, *.bie), Khoros VIFF (*.viff), Kodak Cineon (*.cin), Magick (*.miff), Matlab (*.mat), MTV Raytracing
Image (*.mtv), Palm Pixmap  (*.palm), Portable Bitmap (*.pbm, *.pgm, *.ppm, *.pxm), Scalable Vector Graphic
(*.svg), Seattle File Works (*.pwp), SGI Wavefront (*.rla, *.rpf), Pagis Pro (*.xif), SGI (*.bw, *.rgb, *.rgba, *.sgi),
SMTPE DPX (*.dpx), Sun Rasterfile (*.sun), Truevision Targa (*.tga, *.targa, *.icb, *.vda, *.vst, *.win), Vicar
Rasterfile (*.vicar), XWindows Bitmap (*.xbm) and XWindows Pixmap (*.xpm)
 
All common image formats are supported.  Less common formats may require downloading the formats plug in from:
 
http://www.xequte.com/smartpix/plugins.html 

 
• Raw Camera Image Formats:

Camera Digital Negative (*.dng), Camera Raw Photo (*.raw), Canon Raw Photo (*.cr2, *.crw), Fuji Raw Photo
(*.raf), Kodak Raw Photo (*.dcr), Minolta Raw Photo (*.mrw), Nikon Raw Photo (*.nef), Olympus Raw Photo
(*.orf), Sigma Raw Photo (*.x3f), Sony Raw Photo (*.arw, *.srf)
 

• Video Formats:
Windows Audio-visual (*.avi), Audio Visual Stream (*.asf), Indeo Video (*.ivf), MPEG Movie (*.m1v, *.mpe,
*.mpeg, *.mpg, *.mp4), Apple QuickTime (*.mov, *.qt), Windows Media (*.wm, *.wmv)
 
Support for some formats will depend upon the multimedia drivers that are installed on your version of Windows.

 
• Sound Formats:

MIDI (*.mid, *.rmi), Wave (*.wav), Audio Interchange (*.aif, *.aiff), Compressed Audio Interchange (*.aifc), UNIX
Audio (*.au), MPEG audio stream (*.mpa), MPEG Audio Stream, Layer II (*.mp2), MPEG Audio Stream, Layer
III (*.mp3), Real Audio (*.ra), RIFF-MIDI (*.rmi), PCM Sound (*.snd), Windows Media Audio (*.wma)
 
Support for some formats will depend upon the multimedia drivers that are installed on your version of Windows.

 
• Text Formats:

Standard Text (*.txt), Rich Text (*.rtf) and Comma Separated Value Files (*.csv)
 

• Common Windows Formats:
Support for these formats depends on your Windows installation

 
- TrueType and OpenType Fonts (*.ttf)

 
This format will display on all systems

 
- Web Pages (*.htm, *.html, *.mht, *.xml)

 
For web pages to be displayed you will need to have Internet Explorer v3.0 or greater installed

 
- Office Formats: Word Document (*.doc), Excel Document (*.xls), PowerPoint Document (*.ppt, *.pps)
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For these formats to be displayed you will need to have the relevant Office software installed
 

- Other Formats supported by Browser Plug-ins
 

To display the following formats you will need to have the relevant browser plug-in installed on your system.  These
plug-ins can be downloaded free from the given web sites.  You can also add support for any other format which
provides an IE browser plug-in by clicking 'Add..'

 
Adobe Acrobat (*.pdf):  Download from: http://www.adobe.com

 
DrSid Image Files (*.sid):  Download from: http://www.lizardtech.com
 
DjVu Documents (*.djvu):  Download from: http://www.lizardtech.com

 
Flash Documents (*.fla): Plug-in generally included with Explorer

 
Shockwave Documents (*.swf): Plug-in generally included with Explorer

 
 

• Supporting Other formats:
There are three ways to support other formats:
 

- External Launching
 

All other formats can be viewed by launching them into their default viewer under Windows, you can set this to occur
on either happen on a single or double click

 
- Browser Plug-ins
 

Any format which can be displayed within Internet Explorer using a plug-in, such as Adobe Acrobat files, can be
displayed by Smart Pix Manager.  To add support for the file type, select the 'File Extensions' tab and click 'Add and
Select' beside the Common format.  Then click 'Add..' and enter the extension (for example, *.pdf).

 
 
 

Also:
• Supported Formats Overview
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Managing your Media Libraries
 
If you are using multiple media libraries you can use the media library management utility for moving, copying and deleting
your media libraries (Registered Version only, to move media libraries in the unregistered version click here).
 
Select Library > Manage Media Libraries to display the media library management dialog.
 
 
You will first need to select the media library to manage:
 

Click on the top right browse button and select the folder of the media library you want to move or delete.  Note that you
cannot move or delete the currently opened media library, switch to a new media library first.  If you are not sure of the
location of a media library, open it and then select Library > Media Library Info.

 
 
Moving a Media Library:

1. Click on 'Move the media library', then browse to the folder where you want to move it to.  You cannot select a folder
where a media library already exists.

2. Click OK.
 
 
Copying a Media Library:

1. Click on 'Copy the media library', then browse to the folder where you want to copy it to.  You cannot select a folder
where a media library already exists.

2. Click OK.
 
After you have copied a media library it is recommended that you rename either the original or the copy with a new media
library name, so that it can easily be opened using the Re-open menu item.

 
 
Deleting a Media Library

1. Click on 'Delete the media library'.  
2. Click OK.

 
If the media library is using: 
• False extensions for image files:  Deleting the media library will leave all image files listed in it with the altered

extension, so you will not be able to view them.  Before deleting the media library you should first open it and convert
the storage method back to Normal, this will rename all files to their original extension.

• Media Library File Storage:  Deleting the media library will also delete all files stored in the media library!  If you
want to keep these files but still delete the media library, you should first open it and convert the storage method
back to Normal, this will save all files to their original locations.

 
 
Controls:

• Menu:  Library > Manage Media Libraries
 
 
 
Also:

• Using Multiple Media Libraries
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Back up and Restoration of your Media Library
 
If you are using Smart Pix to its full potential and have catalogued all your files, then there is now significant value held in the
Smart Pix media library files.  To lose these files either by accidental deletion, hard drive failure or file corruption would be too
painful to think about.  Consequently it is important that you regularly back up your files.
 
There are two options:

• Back up media library to a text file
Advantages: Small back up file that can be imported by various applications
Disadvantages: Does not back up file stored within the media library if you are using Library File Storage

 
• Back up media library files

Advantages: Faster to back up
 

 
The two methods are described below.
 
 
Backing Up to a Text File
 

Backing up your files to a text file is a simple one-click process, simply select Library > Import and Export>Backup
Library to File
 
This will export your media library to a text file which can easily be imported back into Smart Pix or other applications.
 
You can also automate this process using a scheduler by calling Smart Pix with the parameter /BACKUP 
 
E.g. "C:\Program Files\Smart Pix Manager\smartpix.exe" /BACKUP
 
Which will instruct Smart Pix to write a back up file and then exit.

 
 

Full Back Up of Media Library Files
 

Alternatively you can back up all of your key Smart Pix files.  On a regular basis, weekly or monthly depending how often
you use Smart Pix, you will want to copy these files to another drive, or incorporate them into your regular backup plan.
 You can use the Manage media library dialog to copy your media library to another drive for back up.
 
 
The data files of importance are:

 
Media Library files:

Spm_dfkw.dat
Spm_dfkw.idx
Spm_file.blb
Spm_file.dat
Spm_file.idx
Spm_info.dat
Spm_info.idx
Spm_keyw.dat
Spm_keyw.idx
Spm_kygp.dat
Spm_kygp.idx
Spm_link.dat
Spm_link.idx
Spm_path.dat
Spm_path.idx
Spm_cust.txt

 

Page 113



Favorites Lists:
*.fvt

 
 

If you need to restore from back up:
 
Note: If you get an error when loading your Library files it is likely that they have become corrupted, such as by a
Windows crash, in this case you probably can fix them by using the rebuild utility on our support page at 
http://www.xequte.com/support/
 
1.  Close Smart Pix
2.  Move all the above files from the folder of the media library you are currently using to a temp folder
3.  Copy your back up files into the folder
4.  Re-run Smart Pix

 
 
 
Also:

• Managing your media libraries
• Importing and Exporting to a text file
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Using Relative Paths
 
If you have been supplied a pre-built media library, e.g. a CD/DVD of categorized images, you may have noticed that the
source folders contain a % sign instead of a drive letter.  This % sign is a relative path, that is instead of using an exact path,
e.g. 'd:\my pictures' the media library will contain relative paths, e.g. '%:\my pictures' where the percentage sign is
automatically replaced by the drive letter for your CD/DVD drive (though in actuality it does not need to be a CD/DVD drive,
e.g. you could copy all your files to your hard drive and use that letter instead).  In this way other users of the same pre-built
media library don't need to relocate all their source folders to access the images they simply need to set this value.  
 
If you are planning to deploy a Smart Pix media library on CD/DVD read these important tips.
 
 
Creating Relative Paths
 

If you are building a media library of categorized images where you will supply the images and media library to other users
then it is advised that you use relative paths.
 
For example, let's say you have a set of images in C:\images that you will supply to users on CD/DVD, if you set the
CD/DVD value to 'C' then your source folder will appear as %:\images.  If you then use the same folder structure on your
CD/DVD then when you supply it to other users then Smart Pix will automatically replace the % with their drive letter so
that they can access the images without having to configure their source folders.
 
 

An Example
 
Let's say that your source folders are currently:
 

C:\My Images\Cars\Porsche
C:\My Images\Cars\Ferrari
C:\My Images\Cars\Honda

 
You plan to copy these images and the Smart Pix media library onto your CD/DVD.  The images will be in the folders of
the CD/DVD at:
 

Z:\Cars\Porsche
Z:\Cars\Ferrari
Z:\Cars\Honda

 
Where Z represents your drive letter.
 
Here is the process:
 
1.Go into media library settings using Library > Settings and Source Folders and select the Source Folders tab
2.If the value for 'CD/DVD Drive/Value of Wildcard' is not blank then clear it by clicking 'Clear Wildcard from all folders
3.Set the value for 'CD/DVD Drive/Value of Wildcard' to the part of the path name which will change, in our example it is

C:\My Images
4.Click OK
5.You will be prompted if you want to set all of your folders to the new wildcard.  Click 'Yes'
6.Go back into Settings and Source Folders, Source Folders tab.  All of the folders that had the old path will now contain

the wildcard symbol (%).  In our example, they would appear as:
 

%\Cars\Porsche
%\Cars\Ferrari
%\Cars\Honda

 
Now when you give your media library CD to someone else, Smart Pix will automatically check for their CD/DVD drive and
read all images from the CD/DVD location, for example, the image %\Cars\Porsche\boxster.jpg would be read as
Z:\Cars\Porsche\boxster.jpg (assuming that there CD/DVD drive is Z)
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Wildcards need not only be used for CDs/DVDs, you might also use it if you frequently change the location of the images.
 For example if you initially had the above folders but had changed the location to (Not using Smart Pix):
 

J:\Image Collection\Cars\Porsche
J:\Image Collection\Cars\Ferrari
J:\Image Collection\Cars\Honda

 
Then use the above steps 1-6 then when you have finished set the value of the wildcard to the new location  (in this
example, 'J:\Image Collection')
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Archiving Files to CD or DVD
 
If your files are taking up too much space on your hard drive then you may want to archive them to CD or DVD.  Smart Pix
allows files to be written directly to compatible CD or DVD writers. You will need to install the plug-in from:
 
http://www.xequte.com/smartpix/plugins.html
 
NOTE: 

• If you are looking to distribute a CD/DVD with a Smart Pix media library to others, read the Media Library CD
Distribution section.  

• If you want to create slideshow disks for sharing with friends and family read the Create Slideshow CD/DVD section
 
 
Here are the steps to archiving your files to CD or DVD:
 
 
1.  Select the files to archive
 

In the main window select the files that you want to add to the CD. If the files are in multiple folders you might want to add
the files to a favorites list and then make your selection in Favorites mode.
 
Select File > Archive to CD... to display the Archive dialog. Take note of the total file size that is displayed. It will need to
be less than the capacity of the device you are writing to (e.g. for a CD the capacity will be around 650MB).
 

 
2.  Specify how to mark archived files
 

After you have archived your files to CD, you may want to move them or remove them from your hard drive. For safety,
Smart Pix dos not allow you to delete them directly, but once you have moved them to another folder and confirmed they
are safely archived you can delete them yourself.
 
NOTE: No changes will be made to your media library or files until after the archival has completed and Smart Pix has
confirmed that the files have copied correctly.

 
 
3.  How do you want your media library to be updated?
 

There are two possibilities for updating your media library which will depend on the reason you chose to archive them:
• If you copied them to CD just as a back-up of your collection then you probably do not want to modify your media

library
• If you are moving them to CD to clear up space on your hard disk and intend to delete the originals, then you will want

to move existing media library listing to the new location (on the CD) so you can still browse them in your media
library (you will be prompted which CD to insert when you try to view them).

 
4.  Other Options: 
 

Name for the Disk
 

This name will be used as the volume name of the CD/DVD. If you have chosen to redirect the media library references
to the disk then you should write this name on the disk because Smart Pix will tell you to insert it when you select
one of its images from your media library file list.

 
Add an HTML Index to the Disk
 

If checked, an HTML index will be added to the CD/DVD, listing all of the files that have been archived
 
Create Library Thumbnails for these files
 

If you select this option thumbnails for your archived images will be inserted into the media library so that you can still
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view them even if the CD is not loaded
 
 
5. Specify your CD or DVD writer settings
 

When you click Next you will need to select the CD or DVD writer and specify any settings that it requires.
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Distributing a Smart Pix Media Library on CD/DVD
 
If you want recipients of your image CD's to be able to search the keywords and descriptions of the images, then you should
ship Smart Pix and your media library with the CD/DVD.  Users do not even need to install or register the software, just run it
directly from the disk.
 
You can distribute Smart Pix Manager with a media library and its associated images on disk, as long as you respect our
license agreement and do not distribute a registered copy (without acquiring a license from Xequte Software).
 
Note: If you want to move files on your existing system to disk that are listed in your media library, read the Archiving to
CD/DVD section instead.
 
 
Important points if you plan to deploy a Smart Pix media library on CD/DVD:
 
1.  Use Relative Paths
 

Your CD drive may be E:\but what if you give your CD of images and a Smart Pix media library to someone whose CD
drive is F:\, he will soon complain that Smart Pix can't find the files!  What do you do?  Use relative paths!
 
Smart Pix allows you to use the % sign to signify the CD drive.
 
Here is the method.
 
i)   Change all of your paths to include the % symbol for what will be the CD drive letter.  This can be done automatically,

here is a complete example.
 
ii)  Copy the images to your CD drive using the same folder paths as they appear on your hard drive
 
When you give your CD to someone Smart Pix will automatically set their wildcard value to the setting of their CD.

 
 
2.  Include Thumbnails
 

If you have sufficient space you should include thumbnails to make the display of files on the disk much quicker.  You can
create media library thumbnails for each file using the Thumbnail Builder.  To display the thumbnail builder, select File >
Options, Media Library 2 tab and click the button 'Edit Thumbnails of the Current Media Library'

 
 
3. Optimize your media library settings
 

Remember the media library settings (i.e. all settings under the Media Library Settings tab in Options) cannot be changed
once the media library is on disk (unless they copy the media library to their hard drive) so it is very important that you
choose them wisely.  For example, if you have set a password then everyone who receives the CD will need to know the
password. 
 
These are the recommended settings:
 
Standard CD image collection:

• Use Keyword Groups:  Yes, if you have more than 30 keywords.
• Read Only: Yes
• Storage Method: Normal (so images can be browsed with or without Smart Pix)
• Password: None

 
Secure CD image collection:

• Use Keyword Groups:  Yes, if you have more than 30 keywords.
• Read Only: Yes
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• Storage Method: Media Library storage (images can only be browsed with Smart Pix)
• Password: Yes

 
 
3.  Smart Pix Manager installation or Run-time?
 

If you copy a run-time of Smart Pix Manager to the disk (i.e. copy all of the files from an installed version of Smart Pix
Manager) then users will be able to run Smart Pix directly from the disk without installation.  Make sure you copy all files
from the \Smart Pix Manager\ folder and place the default media library in a sub-folder of the name \DB\
 
You can include a Smart Pix installation on the disk with your images, however you must include all files within the original
installation and cannot include any username or registration key.  If you would like to include a fully registered version of
Smart Pix on each disk please consult us for OEM discounted pricing.
 
Xequte provides a specialized installer that allows you to install both Smart Pix and a custom media library.  You can
download this from:
 
http://www.xequte.com/smartpix/plugins.html
 
If you have any questions please contact support@xequte.com.

 
 
 

Creating your CD/DVD
 
These are the steps for creating the CD:
 
1.  Copy all of the files in the Smart Pix directory to the top-level folder of your CD/DVD.
2.  Copy the media library files you want to use to a \DB\ folder on your CD/DVD
3.  If you want Smart Pix to auto-run when you insert the CD, download the following file and copy it to the top-level folder of
your CD/DVD:
 
http://www.xequte.com/support/smartpix/cd/autorun.inf
 
Important: Ensure you have used wildcards so that it works even if other people use a different drive letter for the CD/DVD
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Sharing a Smart Pix Media Library on a Network
 
Smart Pix Manager fully supports the sharing of its media library across a network, but you will need to specify the media
library setting, 'Allow media libraries to be shared,' under Media Library Options on all copies of Smart Pix Manager which
are accessing the shared media library
 
 
You will want to consider the following details:
 
1.  Access to Files
 

Naturally every user of the media library will also need to have read access to the images and multimedia files that are
listed in the media library, so these will need to be in a shared folder with a mapped drive letter.  Also you should have the
shared folder mapped to the same letter on all systems, so that, for example, if the media library refers to the file
N:\Images\CompanyLogo.gif then the image can be found in N:\Images on all systems (If this is not possible you will need
to use wildcards or store the files within the media library).

 
 
2.  Read/Write Access
 
There are two ways you can control read/write access to a shared media library:

• Using File Permissions set the user-rights of the media library files as read-only
• Set the Read-Only option on all copies of Smart Pix Manager that do not have write access

 
Note: You can quickly enact the key options for network access by running Smart Pix and click Ctrl+Shift+D
 
 
Also:

• Media Library Options
• Media Library Performance Settings
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What is Registration?
 
Smart Pix Manager is "Shareware".  This means that legally you are entitled to evaluate the software for up to 30 days without
any obligation to pay.  After 30 days, if you continue to use it, you must register your copy with us for a small fee.
 
Registration entitles you free technical support and updates (though not upgrades) to the software.  Registration also entitles
you to discounts on upgrades and may also entitle you to discounts on other software releases from Xequte.  We will also
send you information bulletins by email to let you know about what's happening with Xequte's products.
 
Why should I Purchase?
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Why should I Purchase?
 
Main benefits from Purchasing:
 
 
EXTRA FUNCTIONALITY

1. Creation of Slideshow CD/DVD Disks
2. Archiving files directly to CD or DVD
3. Creation of HTML thumbnail indexes so you can view your images with your web browser
4. Added option of having Smart Pix Manager automatically change and support false extensions for image files (e.g.

MyImage.SPM) so they are not viewable in other programs
5. Added option of storing your files within your Smart Pix media library for a very high level of security
6. Password protection
7. Automatic checking for duplicate files within your collection.
8. Exporting of media library entries
9. Removal of the limit of 8000 files

 
SUPPORT
 

If you should have any problems with the program you can contact us for a solution.
 
 
HAVE YOUR SAY
 

Smart Pix Manager has largely been developed with ideas of my own and feedback from registered users. This does not
necessarily mean it does what you want it to do.  The best way to ensure that Smart Pix Manager performs to your liking
is to register your software and ply me often with your recommendations for enhancements and new features.  If I add it,
you may be acknowledged in the documentation and will receive the new version free! 

 
 
BEST OF ALL- IT'S INEXPENSIVE AND ORDERING IS QUICK
 

Registration is easy and cheap (less than US$40), so purchase now!
 
 
How can I Purchase?
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How can I Purchase?
 
You can order Smart Pix Manager in the following ways:
 
1.  Register online with our Secure Server (Credit Card only!)
 

Direct your browser to http://www.xequte.com/order/
 
Follow the instructions.

 
 
2.  Via standard Post
 

Go to the registration form and print it out.
Send completed form and payment to:
 
Xequte Software 
PO Box 83087
Johnsonville 6440
New Zealand

 
 
3.  Via E-mail (Credit Card only!)
 

Go to the registration form and copy all the text.  Then paste it into an e-mail and fill in the details.
 
Forward to sales@xequte.com
 
For extra security you might like to send the part of the credit card in your main e-mail and the rest in another.  (e.g. write
your number as 4545-5555-xxxx-xxxx in the first e-mail and then xxxx-xxxx-2121-2121 in the second)
 
 

 
Cost: 
 

US$39.50 per copy
 
If you intend to purchase multiple copies please contact us for discounted pricing.
 
You can use the world currency converter at http://www.oanda.com/converter/classic to convert this to your own currency

 
 
Includes:

* Full registered version 
* 12 months e-mail support 
* Free Updates 
* Discounts on other Xequte products and Upgrades

 
 
Payment by:

• Credit card (Visa, MasterCard, American Express, etc )
• Personal Check (Must be in your own currency!  I.e. if you have a Canadian bank send a cheque in Canadian dollars)
• Cash (Note: with cash payments we cannot be held liable for any loss. Do not send coinage, only notes)

 
 
Notes on payment in your own currency
 

If you are sending currency other than US dollars (or sending checks):
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• Using a newspaper or the world currency converter (http://www.oanda.com/converter/classic), convert the US$ value
to your own currency using the US$ buy price.

• Record the date at which you worked out the conversion rate.
• If paying by cash, round the result UP to the nearest paper note (or notes), i.e. 3,926 yen, send four 1,000 yen notes.

 
 
We will confirm receipt of your order within 24 hours (excluding weekends and public holidays) by e-mail and supply you with
a registration key. 
 
Note: if you do not have an e-mail address we will reply by standard post only.
 
Smart Pix Manager Order Form
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Order Form
 

SMART PIX MANAGER ORDER FORM
 
Customer Details: 
 
First Name: ____________________
 
Last Name:____________________
 
 
E-mail Address: ____________________
 
Please confirm e-mail: ____________________
 
Address: ____________________
 
____________________
 
City: ____________________
 
 
State/Province: ____________________
 
Postal Code: ____________________
 
Country: ____________________
 
Phone: ____________________   [ ]Day?  [ ]Night?
 
 
Payment method: 
[ ]Credit card, [ ]Personal Cheque, [ ]Cash.
 
CREDIT CARD DETAILS:
[ ] Visa
[ ] Mastercard
[ ] American Express
[ ] _________________
 
Credit Card #:  ____________________   
 
Expiration Date:  __/__/__(MM/DD/YY or MM/YY)
 
Name on card: ____________________
 
 
PERSONAL CHECK DETAILS
 
Name on check: ____________________ 
 
Check number: ____________________ 
 
Currency: ____________________ 
 
Conversion rate: ____________________ 
 
Date of this rate: ____________________ 
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CASH DETAILS
 
if other than US$:
 
Currency: ____________________ 
 
Conversion rate: ____________________ 
 
Date of this rate: ____________________
 
 
Items required: 
 
Sma
rt
Pix
Man
ager,
____
copi
es
at
US$
39.5
0

US$
____
_

Total
:

   US
$___
__

 
(You can use the world currency converter at http://www.oanda.com/converter/classic to convert this into your own currency)
 
Order confirmation should be:
[ ]Posted 
[ ]E-mailed 
 
 
Other:
 
Where did you hear about this product?
 
___________________________________________
 
 
What improvements would you like us to make to the program?
 
___________________________________________
 
 
Have you had any problems with the program?
 
___________________________________________
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Licensing Details
 
1.   Distribution
 

This shareware software may be freely distributed, provided that:
 
1.  Such distribution includes only the original archive supplied by Xequte.  You may not alter, delete or add any files in the

distribution archive.
2.  The distribution does not include a registration number or information on disabling the registration features.  You are

also forbidden from distributing a registered version of Smart Pix Manager.
3.  No money is charged to the person receiving the software, beyond reasonable cost of packaging and other overhead.
 
For further information about redistribution of Xequte products e-mail us at sales@xequte.com

 
 
2.   License
 

By receiving and/or using Xequte software products, you accept the following Evaluation and Registered User Agreement.
 This agreement is a binding legal agreement between Xequte and the purchasers, users or evaluators of Xequte's software
and products.

 
 
3.   Evaluation (Unregistered) and Registered User Agreement
 

You may evaluate Smart Pix Manager for maximum of thirty calendar days, after which you must register the program with
Xequte or remove the software from your computer.
 
You may allow other users to evaluate copies of the unregistered Shareware.   All evaluation users are subject to the terms
of this agreement.
 
The evaluator/user/buyer/owner is not allowed to attempt to reverse engineer, disassemble or decompile Xequte software
and products. 
 
Xequte's name and any logo or graphics file that represents our software may not be used in any way to promote products
other than our software.  All parts of Xequte software and products are copyright protected.  No program, code, part,
image, video clip, audio sample, text or computer generated sequence of images may be copied or used in any way by the
user except as intended within the bounds of the single user program.
 
The evaluator/user/buyer/owner of Xequte software will indemnify, hold harmless, and defend Xequte against lawsuits,
claims, costs associated with defense or accusations that result from the use of Xequte software. 
 
Xequte is not responsible for any damages whatsoever, including loss of information, interruption of business, personal
injury and/or any damage or consequential damage without limitation, incurred before, during or after the use of our
products.  Our entire liability, without exception, is limited to the customers' reimbursement of the purchase price of the
software (maximum being the suggested retail price as listed by Xequte) in exchange for the return of the product, all
copies, registration papers and manuals, and all materials that constitute a transfer of ownership from the customer back
to Xequte.
 
Each registered copy of Xequte software may be used in only one single location by one user.  Use of the software means
that you have loaded the program and run it or have installed the program onto a computer.  If you install the software onto
a multi-user platform or network, each and every individual user of the software must be registered separately, except only
in the case of a multiple user site licence, in which case you are limited to the number of users as expressly stated on
your multiple user site licence contract.
 
You may make one copy of the registered software for backup purposes, providing you only have one copy installed on one
computer being used by one person.   If any person other than yourself uses Xequte's software registered in your name,
regardless of whether it is at the same time or different times, then you are considered to be in violation of this agreement.
 
The sale of and or distribution of registered copies of this software is strictly forbidden.  It is a violation of this agreement to

Page 128

mailto:sales@xequte.com


loan, rent, lease, borrow, or transfer the use of registered copies of Xequte software products.
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Getting Technical Support
 
Xequte provides technical support to registered users.  This support includes help on any technical or functional problems you
may experience with Smart Pix Manager.  
 
You should first check the troubleshooting FAQ this can be accessed under the Help menu of Smart Pix Manager
 
If this doesn't shed any light then send a message to support via our support page:
 
http://www.xequte.com/support/
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Feedback
 
We are always keen to receive feedback on our programs from users.  Please e-mail us at sales@xequte.com or via standard
mail at
 

Xequte Software
PO Box 83-087, 
Johnsonville 6440, 
New Zealand
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Updates
 
Updates can be downloaded from our web page at:
 
http://www.xequte.com
 
We send information about updates and upgrades to all registered and other interested users via e-mail.  To subscribe to the
list send an e-mail to sales@xequte.com with the subject 'Subscribe'
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BMP format, use of BMP format is recommended for images that you will edit and re-save.  Whereas JPEG files lose a
little bit of their quality every time they are saved, BMP files maintain the same level of quality.  BMP files are generally very
large.
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What is a Media Library?
 
A media library is a database of all your multimedia files, along with their keywords, descriptions, and thumbnails. When you
select the media library tab on the main window you will see a list of all the files in your media library and case search on
particular keywords or descriptions. The media library is also accessed when you select a file in Folders or Favorites modes
so that Smart Pix can display the keywords and description for the file.
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JPEG format is recommended for any files that you intend to view but not edit, because they have the most effective
compression algorithm, i.e. you get the smallest file sizes.  If you have an image collection stored in BMP or PCX format then
you are likely to significantly reduce the disk space requirement by converting the files to JPEG.  However it is important to
realize that in compressing files to JPEG some picture degradation occurs.
 
Whenever you save a JPEG you are asked for a compression setting.  100%  means little compression, i.e. big file, high
quality.   1% means maximum compression, i.e. small file, low quality.  We recommend using 75%, at this level you receive
little noticeable image degradation, but a significant amount of compression will be obtained so the file size will be very small.
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Keywords
 
In Smart Pix we use the term 'keyword' to refer to the descriptive words or phrases that you assign to an image.  For
example, you might add the keywords, 'German', 'blue', 'sports car' to a picture of a blue Porsche.  In this way if you perform a
search for German sports cars this file will be one of those returned.
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Maintained Aspect Ratio
 
This means that while a picture may be zoomed in or out, Smart Pix Manager ensures that it doesn't change the original x
and y dimensions of the image relative to each other.  In other words, if you have a picture 5-cm wide by 10-cm high no matter
how you zoom or shrink it the height will remain twice the width.
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Media Library Listing
 
In this context, a listing is a link in your media library to a file, or in other words 'information (stored in the media library) on
how to locate a particular file' 
 
For each file Smart Pix only stores its location in its media library, i.e. the media library contains information on where the file
is located on your hard drive, but not a copy of the file itself (unless you are using media library file storage).
 
When we say that a file is listed in the media library, we mean that somewhere in our media library there is information on
that file and its location.

Page 138



Source Folders
 
At the core of your Smart Pix media library is a list of source folders.  You need to inform Smart Pix where on your computer
your files are located, these locations are termed 'source folders'.  Not only does this information allow Smart Pix to know
where to find your files but it also tells it where to look for new files when you perform an update.
 
Smart Pix does not change the files in these folders in any way (unless you choose to use a false extension or Media Library
Storage).
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